summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/mbuffer/mbuffer-20070911.ebuild')
-rw-r--r--sys-block/mbuffer/mbuffer-20070911.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-block/mbuffer/mbuffer-20070911.ebuild b/sys-block/mbuffer/mbuffer-20070911.ebuild
new file mode 100644
index 000000000000..21305204209e
--- /dev/null
+++ b/sys-block/mbuffer/mbuffer-20070911.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/mbuffer/mbuffer-20070911.ebuild,v 1.1 2007/09/11 20:04:56 vapier Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="M(easuring)buffer is a replacement for buffer with additional functionality"
+HOMEPAGE="http://www.maier-komor.de/mbuffer.html"
+SRC_URI="http://www.maier-komor.de/software/mbuffer/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug ssl"
+
+RDEPEND="ssl? ( dev-libs/openssl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-20070317-configure.patch
+ epatch "${FILESDIR}"/${PN}-20070317-mandir.patch
+ sed -i 's: -O : :' Makefile.in
+}
+
+src_compile() {
+ econf \
+ $(use_enable ssl md5) \
+ $(use_enable debug) \
+ || die "econf failed"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS INSTALL NEWS README ChangeLog
+}