summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/parted/parted-2.2.ebuild')
-rw-r--r--sys-apps/parted/parted-2.2.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys-apps/parted/parted-2.2.ebuild b/sys-apps/parted/parted-2.2.ebuild
index 26fb3bd1ae43..c2af226e1abf 100644
--- a/sys-apps/parted/parted-2.2.ebuild
+++ b/sys-apps/parted/parted-2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-2.2.ebuild,v 1.1 2010/02/26 15:46:20 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-2.2.ebuild,v 1.2 2010/05/17 11:31:15 jer Exp $
EAPI="2"
@@ -38,6 +38,14 @@ src_configure() {
--disable-Werror || die "Configure failed"
}
+src_test() {
+ if use debug; then
+ emake check || die "emake check failed"
+ else
+ ewarn "Skipping tests because USE=-debug is set."
+ fi
+}
+
src_install() {
emake install DESTDIR="${D}" || die "Install failed"
dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO