summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/diffutils/diffutils-2.8.4-r4.ebuild')
-rw-r--r--sys-apps/diffutils/diffutils-2.8.4-r4.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild b/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild
deleted file mode 100644
index 2cdcd7edcb5a..000000000000
--- a/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild,v 1.22 2005/01/04 03:43:28 vapier Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Tools to make diffs and compare files"
-HOMEPAGE="http://www.gnu.org/software/diffutils/diffutils.html"
-SRC_URI="ftp://alpha.gnu.org/gnu/diffutils/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls static"
-
-RDEPEND="virtual/libc"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # Build fails with make -j5 or greater on pentium4. This is because
- # the jobs creating the opjects, which depend on paths.h is sheduled
- # at the same time paths.h is generated. This patch just fix a small
- # typeo that caused this. This closes bug #8934.
- # <azarah@gentoo.org> (14 Oct 2002)
- epatch ${FILESDIR}/${P}-Makefile-fix-typeo.patch
-
- # Removes waitpid() call after pclose() on piped diff stream, closing
- # bug #11728, thanks to D Wollmann <converter@dalnet-perl.org>
- epatch ${FILESDIR}/${P}-sdiff-no-waitpid.patch
-
- # --tabsize option, undocumented in diff but used in sdiff, makes
- # diff dump core, closing #24238.
- # <taviso@gentoo.org> (1 Aug 2003)
- epatch ${FILESDIR}/${P}-tabsize-dumps-core.diff
-
- # Make sure we don't try generating the manpages ... this requires
- # 'help2man' which is a perl app which is not available in a
- # stage2 / stage3 ... don't DEPEND on it or we get a DEPEND loop :(
- # for more info, see #55479
- touch man/*.1
-}
-
-src_compile() {
- econf $(use_enable nls) || die "econf"
- use static && append-ldflags -static
- emake LDFLAGS="${LDFLAGS}" || die "make"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
- dodoc ChangeLog NEWS README
-
- # use the manpage from 'sys-apps/man-pages'
- rm -f "${D}"/usr/share/man/man1/diff.1*
-}