summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/coq/coq-8.2.ebuild')
-rw-r--r--sci-mathematics/coq/coq-8.2.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/sci-mathematics/coq/coq-8.2.ebuild b/sci-mathematics/coq/coq-8.2.ebuild
deleted file mode 100644
index d76d4eea117f..000000000000
--- a/sci-mathematics/coq/coq-8.2.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.2.ebuild,v 1.3 2009/09/18 16:29:58 tove Exp $
-
-EAPI="2"
-
-inherit eutils multilib
-
-MY_PV="${PV/_p/pl}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="Coq is a proof assistant written in O'Caml"
-HOMEPAGE="http://coq.inria.fr/"
-SRC_URI="http://coq.inria.fr/V${MY_PV}/files/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="norealanalysis gtk debug +ocamlopt doc"
-
-RDEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]
- >=dev-ml/camlp5-5.09[ocamlopt?]
- gtk? ( >=dev-ml/lablgtk-2.10.1[ocamlopt?] )"
-DEPEND="${RDEPEND}
- doc? ( dev-tex/hevea virtual/latex-base )"
-
-S="${WORKDIR}/${P/_/}"
-
-src_configure() {
- ocaml_lib=`ocamlc -where`
- local myconf="--prefix /usr
- --bindir /usr/bin
- --libdir /usr/$(get_libdir)/coq
- --mandir /usr/share/man
- --emacslib /usr/share/emacs/site-lisp
- --coqdocdir /usr/$(get_libdir)/coq/coqdoc
- --docdir /usr/share/doc/${PF}
- --camlp5dir ${ocaml_lib}/camlp5
- --lablgtkdir ${ocaml_lib}/lablgtk2"
-
- use debug && myconf="--debug $myconf"
- use norealanalysis && myconf="$myconf --reals no"
- use norealanalysis || myconf="$myconf --reals all"
- use doc || myconf="$myconf --with-doc no"
-
- if use gtk; then
- use ocamlopt && myconf="$myconf --coqide opt"
- use ocamlopt || myconf="$myconf --coqide byte"
- else
- myconf="$myconf --coqide no"
- fi
- use ocamlopt || myconf="$myconf -byte-only"
- use ocamlopt && myconf="$myconf --opt"
-
- export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
- ./configure $myconf || die "configure failed"
-}
-
-src_compile() {
- emake -j1 || die "make failed"
-}
-
-src_install() {
- emake COQINSTALLPREFIX="${D}" install || die
- dodoc README CREDITS CHANGES
-
- use gtk && domenu "${FILESDIR}/coqide.desktop"
-}