summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/lapack-atlas/lapack-atlas-3.7.11-r1.ebuild')
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.7.11-r1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.7.11-r1.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.7.11-r1.ebuild
index dffee25e4b23..2548dd6f490c 100644
--- a/sci-libs/lapack-atlas/lapack-atlas-3.7.11-r1.ebuild
+++ b/sci-libs/lapack-atlas/lapack-atlas-3.7.11-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.7.11-r1.ebuild,v 1.7 2007/01/23 13:57:22 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.7.11-r1.ebuild,v 1.8 2007/10/10 10:04:59 markusle Exp $
inherit eutils flag-o-matic toolchain-funcs fortran
@@ -74,15 +74,15 @@ src_unpack() {
einfo "Making ${PN} respect compiler settings"
sed -i \
-e "s:\(\t./xconfig\):\1 -m $(tc-getCC) -c $(tc-getCC) -f ${FORTRANC}:g" \
- ${S}/Makefile \
+ "${S}"/Makefile \
|| die "Failed to fix compilers"
if [[ $(gcc-major-version) -ge 4 ]]; then
einfo "Updating Makefiles for gcc-4"
sed -i \
-e "s:g2c:gfortran:g" \
- ${S}/Make.top \
- ${S}/makes/Make.lib \
+ "${S}"/Make.top \
+ "${S}"/makes/Make.lib \
|| die "Failed to update for gcc-4"
fi
@@ -92,7 +92,7 @@ src_unpack() {
else
libs="-lpthread -lg2c"
fi
- sed -e "s/SHRD_LNK/${libs}/g" -i ${S}/Make.top || \
+ sed -e "s/SHRD_LNK/${libs}/g" -i "${S}"/Make.top || \
die "Failed to add addtional libs to shared object build"
}
@@ -198,7 +198,7 @@ src_install () {
libtool --mode=install install -s liblapack.la "${D}/${RPATH}" || die
fi
- eselect lapack add $(get_libdir) ${FILESDIR}/eselect.lapack atlas
+ eselect lapack add $(get_libdir) "${FILESDIR}"/eselect.lapack atlas
insinto /usr/include/atlas
cd "${S}"/include