summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/raster3d/raster3d-2.7s.ebuild')
-rw-r--r--sci-chemistry/raster3d/raster3d-2.7s.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sci-chemistry/raster3d/raster3d-2.7s.ebuild b/sci-chemistry/raster3d/raster3d-2.7s.ebuild
index b649e8afc1b9..12095f0048de 100644
--- a/sci-chemistry/raster3d/raster3d-2.7s.ebuild
+++ b/sci-chemistry/raster3d/raster3d-2.7s.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/raster3d/raster3d-2.7s.ebuild,v 1.2 2008/07/08 03:07:27 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/raster3d/raster3d-2.7s.ebuild,v 1.3 2008/10/16 14:01:23 markusle Exp $
inherit toolchain-funcs fortran
@@ -25,7 +25,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${NAME}_${PV}"
src_compile() {
- cd "${S}"
+ # some source files have lines that extend
+ # beyond 72 characters causing problems with
+ # gcc-4.1.2 without the below
+ FFLAGS="${FFLAGS} -ffixed-line-length-132"
# fix Makefile to honor user's CFLAGS/FFLAGS
sed -e "s:gcc:$(tc-getCC):" \