summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/gnubiff/gnubiff-2.1.9.ebuild')
-rw-r--r--net-mail/gnubiff/gnubiff-2.1.9.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-mail/gnubiff/gnubiff-2.1.9.ebuild b/net-mail/gnubiff/gnubiff-2.1.9.ebuild
new file mode 100644
index 000000000000..6c618ec75316
--- /dev/null
+++ b/net-mail/gnubiff/gnubiff-2.1.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.1.9.ebuild,v 1.1 2006/01/30 17:25:42 agriffis Exp $
+
+inherit eutils
+
+DESCRIPTION="A mail notification program"
+HOMEPAGE="http://gnubiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE="gnome password"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=gnome-base/libglade-2.3
+ gnome? ( >=gnome-base/libgnome-2.2
+ >=gnome-base/libgnomeui-2.2 )
+ fam? ( app-admin/fam )
+ !fam? ( app-admin/gamin )"
+
+DEPEND="${RDEPEND}
+ gnome? ( dev-util/pkgconfig )"
+
+src_compile() {
+ local myconf
+
+ if use password; then
+ einfo "generating random password"
+ myconf="${myconf} --with-password --with-password-string=${RANDOM}${RANDOM}${RANDOM}${RANDOM}"
+ fi
+
+ econf $(use_enable gnome) $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS AUTHORS ChangeLog COPYING INSTALL NEWS README THANKS TODO
+}