summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/pam_ldap/pam_ldap-134-r1.ebuild')
-rw-r--r--net-libs/pam_ldap/pam_ldap-134-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-libs/pam_ldap/pam_ldap-134-r1.ebuild b/net-libs/pam_ldap/pam_ldap-134-r1.ebuild
new file mode 100644
index 000000000000..471603064721
--- /dev/null
+++ b/net-libs/pam_ldap/pam_ldap-134-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/pam_ldap/pam_ldap-134-r1.ebuild,v 1.1 2002/04/20 23:03:48 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PAM LDAP Module"
+HOMEPAGE="http://www.padl.com/pam_ldap.html"
+SRC_URI="ftp://ftp.padl.com/pub/${P}.tar.gz"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/pam-0.72
+ >=net-nds/openldap-1.2.11"
+
+
+src_compile() {
+ aclocal
+ autoconf
+ automake --add-missing
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-ldap-lib=openldap || die
+
+ emake || die
+}
+
+src_install() {
+
+ exeinto /lib/security
+ doexe pam_ldap.so
+
+ dodoc pam.conf ldap.conf
+ dodoc ChangeLog COPYING.* CVSVersionInfo.txt README
+ docinto pam.d
+ dodoc pam.d/*
+}
+