summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/squid-graph/squid-graph-3.2.ebuild')
-rw-r--r--net-analyzer/squid-graph/squid-graph-3.2.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/net-analyzer/squid-graph/squid-graph-3.2.ebuild b/net-analyzer/squid-graph/squid-graph-3.2.ebuild
index e1796b56c842..6d721e53e06c 100644
--- a/net-analyzer/squid-graph/squid-graph-3.2.ebuild
+++ b/net-analyzer/squid-graph/squid-graph-3.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/squid-graph/squid-graph-3.2.ebuild,v 1.2 2008/01/21 14:08:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/squid-graph/squid-graph-3.2.ebuild,v 1.3 2008/05/24 15:11:55 pva Exp $
+
+inherit eutils
DESCRIPTION="Squid logfile analyzer and traffic grapher"
HOMEPAGE="http://squid-graph.sourceforge.net/"
@@ -16,6 +18,13 @@ RDEPEND="${DEPEND}"
S=${WORKDIR}/${PN}
+pkg_setup() {
+ if ! built_with_use dev-perl/GD png; then
+ eerror "${CATEGORY}/${PN} requires dev-perl/GD be built with png USE flag."
+ die "Please, reemerge dev-perl/GD with png USE flag enabled."
+ fi
+}
+
src_install () {
dobin apacheconv generate.cgi squid-graph timeconv || die "dobin failed"
dodoc docs