summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/rrdtool/rrdtool-1.0.48.ebuild')
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.0.48.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-analyzer/rrdtool/rrdtool-1.0.48.ebuild b/net-analyzer/rrdtool/rrdtool-1.0.48.ebuild
index 77c942f1955d..dd5294f65897 100644
--- a/net-analyzer/rrdtool/rrdtool-1.0.48.ebuild
+++ b/net-analyzer/rrdtool/rrdtool-1.0.48.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.48.ebuild,v 1.2 2004/09/03 16:43:10 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.48.ebuild,v 1.3 2004/10/24 16:30:42 eldad Exp $
inherit perl-module flag-o-matic gnuconfig eutils
@@ -10,7 +10,7 @@ SRC_URI="http://people.ee.ethz.ch/%7Eoetiker/webtools/${PN}/pub/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ppc ~sparc ~alpha ~hppa ~amd64 ~ia64"
+KEYWORDS="x86 ppc ~sparc ~alpha ~hppa ~amd64 ~ia64"
IUSE="perl tcltk"
DEPEND="perl? ( dev-lang/perl )
@@ -29,7 +29,11 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${P}-fPIC.patch
+ sed -e 's/^LTCOMPILE = $(LIBTOOL) --mode=compile $(CC)/& -prefer-pic/' -i src/Makefile.in
+
+ if [[ ! $(grep '^LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) -prefer-pic' src/Makefile.in) ]]; then
+ die "Makefile.in sed failed"
+ fi
}
src_compile() {