summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/mplayer/mplayer-1.0_pre3-r5.ebuild')
-rw-r--r--media-video/mplayer/mplayer-1.0_pre3-r5.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/media-video/mplayer/mplayer-1.0_pre3-r5.ebuild b/media-video/mplayer/mplayer-1.0_pre3-r5.ebuild
index 6a8dffd2d121..81eb93ebcb7f 100644
--- a/media-video/mplayer/mplayer-1.0_pre3-r5.ebuild
+++ b/media-video/mplayer/mplayer-1.0_pre3-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_pre3-r5.ebuild,v 1.10 2004/05/12 13:51:58 pappy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_pre3-r5.ebuild,v 1.11 2004/06/09 17:05:36 agriffis Exp $
IUSE="dga oss xmms jpeg 3dfx sse matrox sdl X svga ggi oggvorbis 3dnow aalib gnome xv opengl truetype dvd gtk gif esd fbcon encode alsa directfb arts dvb samba lirc matroska debug joystick theora ipv6 v4l v4l2"
@@ -121,7 +121,7 @@ src_unpack() {
# Fix hppa detection
[ "${ARCH}" = "hppa" ] && sed -i -e "s/9000*/parisc*/" "${S}/configure"
- if [ "`use svga`" ]
+ if use svga
then
echo
einfo "Enabling vidix non-root mode."
@@ -281,7 +281,7 @@ src_compile() {
cd ${S}/libavcodec/libpostproc
make SHARED_PP="yes" || die "Failed to build libpostproc.so!"
- if [ -n "`use matrox`" ]
+ if use matrox
then
cd ${S}/drivers
make all || die "Failed to build matrox driver!"
@@ -318,7 +318,7 @@ src_install() {
cp -r ${S}/TOOLS ${D}/usr/share/doc/${PF} || die
# Install the default Skin and Gnome menu entry
- if [ -n "`use gtk`" ]
+ if use gtk
then
dodir /usr/share/mplayer/Skin
cp -r ${WORKDIR}/Blue ${D}/usr/share/mplayer/Skin/default || die
@@ -328,7 +328,7 @@ src_install() {
dosym mplayer /usr/bin/gmplayer
fi
- if [ -n "`use gnome`" ]
+ if use gnome
then
insinto /usr/share/pixmaps
newins ${S}/Gui/mplayer/pixmaps/logo.xpm mplayer.xpm
@@ -359,7 +359,7 @@ src_install() {
doins ${S}/etc/input.conf
doins ${S}/etc/menu.conf
- if [ -n "`use matrox`" ]
+ if use matrox
then
check_KV
insinto /lib/modules/${KV}/kernel/drivers/char
@@ -377,7 +377,7 @@ pkg_preinst() {
pkg_postinst() {
- if [ -n "`use ppc`" ]
+ if use ppc
then
echo
einfo "When you see only GREEN salad on your G4 while playing"