summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/devede/devede-3.0.ebuild')
-rw-r--r--media-video/devede/devede-3.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-video/devede/devede-3.0.ebuild b/media-video/devede/devede-3.0.ebuild
new file mode 100644
index 000000000000..b84bf627b04f
--- /dev/null
+++ b/media-video/devede/devede-3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/devede/devede-3.0.ebuild,v 1.1 2007/06/24 14:13:47 drac Exp $
+
+DESCRIPTION="DVD Video Creator"
+HOMEPAGE="http://www.rastersoft.com/programas/devede.html"
+SRC_URI="http://www.rastersoft.com/descargas/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=dev-lang/python-2.4
+ dev-python/pygtk
+ >=media-video/mplayer-1.0_rc1
+ media-video/dvdauthor
+ media-video/vcdimager
+ dev-python/psyco
+ virtual/cdrtools"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+# DESTDIR is broken in this version.
+src_unpack() {
+ unpack ${A}
+ sed -i -e 's:usr/local:usr:g' "${S}"/install.sh
+}
+
+src_install() {
+ DESTDIR="${D}" ./install.sh || die "install.sh failed."
+ rm -rf "${D}"/usr/share/doc/devede
+ use doc && dohtml docs/*
+}
+
+pkg_postinst() {
+ elog "To create DIVX/MPEG4 files, be sure that MPlayer is compiled with LAME support."
+ elog "In this case you want to check for both the encode and mp3 USE flags."
+ elog ""
+ elog "To change the font used to render the subtitles, choose a TrueType font you like"
+ elog "and copy it in \$HOME/.spumux directory, renaming it to devedesans.ttf."
+}