summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/bootsplash-themes-livecd/bootsplash-themes-livecd-2004.0.ebuild')
-rw-r--r--media-gfx/bootsplash-themes-livecd/bootsplash-themes-livecd-2004.0.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/media-gfx/bootsplash-themes-livecd/bootsplash-themes-livecd-2004.0.ebuild b/media-gfx/bootsplash-themes-livecd/bootsplash-themes-livecd-2004.0.ebuild
index 97f0676d5ca3..df11c00e1203 100644
--- a/media-gfx/bootsplash-themes-livecd/bootsplash-themes-livecd-2004.0.ebuild
+++ b/media-gfx/bootsplash-themes-livecd/bootsplash-themes-livecd-2004.0.ebuild
@@ -1,28 +1,27 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash-themes-livecd/bootsplash-themes-livecd-2004.0.ebuild,v 1.2 2004/05/20 21:17:48 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash-themes-livecd/bootsplash-themes-livecd-2004.0.ebuild,v 1.3 2004/06/03 22:40:04 wolf31o2 Exp $
IUSE="livecd"
-S=${WORKDIR}/${PF}
+S=${WORKDIR}/livecd-${PV}
DESCRIPTION="Gentoo ${PV} theme for bootsplash consoles"
HOMEPAGE="http://www.gentoo.org/"
SRC_URI="mirror://gentoo/${PF}.tar.bz2
http://dev.gentoo.org/~wolf31o2/livecd/${PF}.tar.bz2"
-SLOT="0"
+SLOT=${PV}
LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="x86 amd64"
DEPEND=">=media-gfx/bootsplash-0.6-r16"
src_install() {
- cp -r * ${D}/etc/bootsplash/themes/livecd-${PV}
+ dodir /etc/bootsplash/livecd-${PV}
+ cp -r ${S}/* ${D}/etc/bootsplash/livecd-${PV}
- # link default config for boot images if not already set
- if [ ! -e ${ROOT}/etc/bootsplash/default ]; then
- use livecd \
- && dosym ./livecd-${PV} /etc/bootsplash/default \
- || dosym ./gentoo /etc/bootsplash/default
- fi
- use livecd && dosed "s:gentoo:livecd-${PV}:" /etc/conf.d/bootsplash
+ # link default config for livecd images if USE=livecd set
+ use livecd \
+ && cd ${D}/etc/bootsplash \
+ && rm default \
+ && dosym ./livecd-${PV} /etc/bootsplash/default
}