summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kopete/kopete-3.5.3-r4.ebuild')
-rw-r--r--kde-base/kopete/kopete-3.5.3-r4.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/kde-base/kopete/kopete-3.5.3-r4.ebuild b/kde-base/kopete/kopete-3.5.3-r4.ebuild
deleted file mode 100644
index a6b8fa1a1fa1..000000000000
--- a/kde-base/kopete/kopete-3.5.3-r4.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-3.5.3-r4.ebuild,v 1.3 2006/11/12 21:03:35 flameeyes Exp $
-
-KMNAME=kdenetwork
-MAXKDEVER=$PV
-KM_DEPRANGE="$PV $MAXKDEVER"
-inherit kde-meta eutils
-
-SRC_URI="${SRC_URI}
- mirror://gentoo/kdenetwork-3.5-patchset-01.tar.bz2"
-
-DESCRIPTION="KDE multi-protocol IM client"
-HOMEPAGE="http://kopete.kde.org/"
-
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="sametime ssl kernel_linux"
-
-# The kernel_linux? ( ) conditional dependencies are for webcams, not supported
-# on other kernels AFAIK
-BOTH_DEPEND="dev-libs/libxslt
- dev-libs/libxml2
- net-dns/libidn
- >=dev-libs/glib-2
- app-crypt/qca
- sametime? ( =net-libs/meanwhile-0.4* )
- || ( (
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXrender
- x11-libs/libXScrnSaver
- ) <virtual/x11-7 )
- kernel_linux? ( virtual/opengl )"
-
-RDEPEND="${BOTH_DEPEND}
- ssl? ( app-crypt/qca-tls )"
-
-DEPEND="${BOTH_DEPEND}
- kernel_linux? ( virtual/os-headers )
- || ( (
- x11-proto/videoproto
- x11-proto/xproto
- kernel_linux? ( x11-libs/libXv )
- x11-proto/scrnsaverproto
- ) <virtual/x11-7 )"
-
-PATCHES="${FILESDIR}/${P}-icqfix.patch
- ${FILESDIR}/${PN}-3.5.x-oscarcontacts.patch
- ${FILESDIR}/${PN}-0.12.1-icqfix3.patch"
-
-pkg_setup() {
- if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
- eerror "To support Video4Linux webcams in this package is required to have"
- eerror "=x11-libs/qt-3* compiled with OpenGL support."
- eerror "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
- die "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
- fi
-}
-
-src_compile() {
- # External libgadu support - doesn't work, kopete requires a specific development snapshot of libgadu.
- # Maybe we can enable it in the future.
- local myconf="$(use_enable sametime sametime-plugin)
- --without-xmms --without-external-libgadu"
-
- kde-meta_src_compile
-}