summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdegraphics/kdegraphics-3.4.2-r2.ebuild')
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.4.2-r2.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/kde-base/kdegraphics/kdegraphics-3.4.2-r2.ebuild b/kde-base/kdegraphics/kdegraphics-3.4.2-r2.ebuild
deleted file mode 100644
index 467ad8fc2f9e..000000000000
--- a/kde-base/kdegraphics/kdegraphics-3.4.2-r2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.4.2-r2.ebuild,v 1.4 2006/04/04 20:53:00 genstef Exp $
-
-inherit kde-dist eutils
-
-DESCRIPTION="KDE graphics-related apps"
-
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
-IUSE="gphoto2 imlib nodrm openexr opengl povray scanner tetex"
-
-DEPEND="~kde-base/kdebase-${PV}
- >=media-libs/freetype-2
- media-libs/fontconfig
- gphoto2? ( media-libs/libgphoto2 )
- scanner? ( media-gfx/sane-backends )
- media-libs/libart_lgpl
- media-libs/lcms
- dev-libs/fribidi
- imlib? ( media-libs/imlib )
- virtual/ghostscript
- media-libs/tiff
- openexr? ( >=media-libs/openexr-1.2 )
- povray? ( media-gfx/povray
- virtual/opengl )"
-
-RDEPEND="${DEPEND}
- app-text/poppler
- tetex? (
- || ( >=app-text/tetex-2
- app-text/ptex
- app-text/cstetex
- app-text/dvipdfm ) )"
-
-DEPEND="${DEPEND}
- dev-util/pkgconfig"
-
-src_unpack() {
- kde_src_unpack
-
- # Fix detection of gocr (kde bug 90082).
- epatch "${FILESDIR}/kdegraphics-3.4.1-gocr.patch"
-
- # Fix regression in kpdf (kde bug 110000). Applied for 3.4.3.
- epatch "${FILESDIR}/kdegraphics-3.4.2-kpdf-fix.patch"
-
- # Fix compilation with gcc4 (kde bug 110249). Applied for 3.4.3.
- epatch "${FILESDIR}/kdegraphics-3.4-gcc4.patch"
-
- # Configure patch. Applied for 3.5.
- epatch "${FILESDIR}/kdegraphics-3.4-configure.patch"
-
- # Fix crash in kpdf (kde bug 110111). Applied for 3.4.3.
- epatch "${FILESDIR}/kdegraphics-3.4.2-kpdf-contentcrash.patch"
-
- # For the configure patch.
- make -f admin/Makefile.common
-}
-
-src_compile() {
- if use gphoto2; then
- myconf="${myconf} --with-kamera \
- --with-gphoto2-includes=/usr/include/gphoto2 \
- --with-gphoto2-libraries=/usr/lib/gphoto2"
- else
- myconf="${myconf} --without-kamera"
- fi
-
- use scanner || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kooka libkscan"
- use povray || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kpovmodeler"
-
- myconf="${myconf} $(use_with imlib) $(use_enable !nodrm kpdf-drm)
- $(use_with openexr)"
-
- kde_src_compile
-}