summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.4.2.ebuild')
-rw-r--r--kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.4.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.4.2.ebuild b/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.4.2.ebuild
new file mode 100644
index 000000000000..18f7fc2d3bea
--- /dev/null
+++ b/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.4.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.4.2.ebuild,v 1.1 2005/07/28 21:16:14 danarmak Exp $
+
+KMNAME=kdegraphics
+KMMODULE=kfile-plugins
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="kfile plugins from kdegraphics"
+KEYWORDS=" ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="tiff openexr"
+DEPEND="tiff? ( media-libs/tiff )
+ openexr? ( media-libs/openexr )"
+RDEPEND="${DEPEND}
+ app-text/xpdf" # needed for "pdfinfo"
+
+# ps installed with kghostview, pdf installed with kpdf
+KMEXTRACTONLY="kfile-plugins/ps kfile-plugins/pdf"
+
+PATCHES="$FILESDIR/configure-fix-kdegraphics-openexr.patch"
+myconf="$myconf $(use_with openexr)"