summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kaddressbook/kaddressbook-3.5_alpha1.ebuild')
-rw-r--r--kde-base/kaddressbook/kaddressbook-3.5_alpha1.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/kde-base/kaddressbook/kaddressbook-3.5_alpha1.ebuild b/kde-base/kaddressbook/kaddressbook-3.5_alpha1.ebuild
deleted file mode 100644
index 85c3b0e01d03..000000000000
--- a/kde-base/kaddressbook/kaddressbook-3.5_alpha1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/kaddressbook-3.5_alpha1.ebuild,v 1.1 2005/09/07 10:44:17 flameeyes Exp $
-
-KMNAME=kdepim
-MAXKDEVER=$PV
-KM_DEPRANGE="$PV $MAXKDEVER"
-inherit kde-meta eutils
-
-DESCRIPTION="The KDE Address Book"
-KEYWORDS="~amd64"
-IUSE="gnokii"
-DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkdepim)
-$(deprange $PV $MAXKDEVER kde-base/libkcal)
-$(deprange $PV $MAXKDEVER kde-base/certmanager)
-$(deprange $PV $MAXKDEVER kde-base/libkdenetwork)
-$(deprange $PV $MAXKDEVER kde-base/kontact)
-gnokii? ( app-mobilephone/gnokii )"
-
-myconf="$myconf $(use_with gnokii)"
-
-KMCOPYLIB="
- libkdepim libkdepim
- libkcal libkcal
- libkleopatra certmanager/lib/
- libqgpgme libkdenetwork/qgpgme/
- libkpinterfaces kontact/interfaces/"
-KMEXTRACTONLY="
- libkdepim/
- libkdenetwork/
- libkcal/
- certmanager/
- kontact/interfaces/
- akregator
- kmail/kmailIface.h"
-KMCOMPILEONLY="
- libkcal/libical/src/libical/
- libkcal/libical/src/libicalss/
- akregator/src/librss"
- # We add them here because they are standard plugins and programs related to kaddressbook but not a dep of any other kdepim program, so they will be lost if noone install them
-KMEXTRA="
- kabc/
- kfile-plugins/vcf
- kontact/plugins/kaddressbook"
-
-src_compile() {
- export DO_NOT_COMPILE="libical" && kde-meta_src_compile myconf configure
- # generate "ical.h"
- cd ${S}/libkcal/libical/src/libical && make ical.h
- # generate "icalss.h"
- cd ${S}/libkcal/libical/src/libicalss && make icalss.h
-
- kde-meta_src_compile "make"
-}