summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gconf/gconf-2.6.1.ebuild')
-rw-r--r--gnome-base/gconf/gconf-2.6.1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnome-base/gconf/gconf-2.6.1.ebuild b/gnome-base/gconf/gconf-2.6.1.ebuild
index 2fd919bb0bf5..1e822c88f8bb 100644
--- a/gnome-base/gconf/gconf-2.6.1.ebuild
+++ b/gnome-base/gconf/gconf-2.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.6.1.ebuild,v 1.9 2005/01/08 23:26:55 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.6.1.ebuild,v 1.10 2005/06/24 22:12:06 agriffis Exp $
inherit eutils gnome2
@@ -50,6 +50,9 @@ src_install() {
touch ${D}/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
touch ${D}/etc/gconf/gconf.xml.defaults/.keep${SLOT}
+ dodir /etc/env.d
+ dodir /root/.gconfd
+
}
kill_gconf () {
@@ -83,10 +86,7 @@ pkg_preinst () {
kill_gconf
- dodir /etc/env.d
- echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${D}/etc/env.d/50gconf
-
- dodir /root/.gconfd
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > ${IMAGE}/etc/env.d/50gconf
}