summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/love/love-9999.ebuild')
-rw-r--r--games-engines/love/love-9999.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/games-engines/love/love-9999.ebuild b/games-engines/love/love-9999.ebuild
index aa826dbc1f3e..cf6f16e4583e 100644
--- a/games-engines/love/love-9999.ebuild
+++ b/games-engines/love/love-9999.ebuild
@@ -1,14 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/love/love-9999.ebuild,v 1.3 2012/04/17 15:06:21 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/love/love-9999.ebuild,v 1.4 2012/04/20 22:56:19 chithanh Exp $
EAPI=3
inherit games
-DESCRIPTION="A framework for 2D games in Lua"
-HOMEPAGE="http://love2d.org/"
-
if [[ ${PV} == 9999* ]]; then
inherit autotools mercurial
EHG_REPO_URI="https://bitbucket.org/rude/${PN}"
@@ -19,6 +16,9 @@ else
KEYWORDS="~amd64 ~x86"
fi
+DESCRIPTION="A framework for 2D games in Lua"
+HOMEPAGE="http://love2d.org/"
+
LICENSE="ZLIB"
SLOT="0"
IUSE=""
@@ -40,7 +40,9 @@ DEPEND="${RDEPEND}
DOCS=( "readme.md" "changes.txt" )
src_prepare() {
- sh platform/unix/gen-makefile || die
- mkdir platform/unix/m4 || die
- eautoreconf
+ if [[ ${PV} == 9999* ]]; then
+ sh platform/unix/gen-makefile || die
+ mkdir platform/unix/m4 || die
+ eautoreconf
+ fi
}