summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/atanks/atanks-0.9.9b.ebuild')
-rw-r--r--games-action/atanks/atanks-0.9.9b.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-action/atanks/atanks-0.9.9b.ebuild b/games-action/atanks/atanks-0.9.9b.ebuild
new file mode 100644
index 000000000000..013f51244328
--- /dev/null
+++ b/games-action/atanks/atanks-0.9.9b.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-0.9.9b.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit games
+
+DATA_DIR="${GAMES_DATADIR}/${PN}"
+S="${WORKDIR}/${PN}"
+DESCRIPTION="Worms and Scorched Earth-like game"
+HOMEPAGE="http://atanks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atanks/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/x11
+ >=sys-apps/sed-4
+ >=media-libs/allegro-4.0.3
+ >=media-libs/allegttf-2.0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:DATA_DIR=.*:DATA_DIR=\\\\\"${DATA_DIR}\\\\\":" src/Makefile || \
+ die "sed src/Makefile failed"
+ sed -i \
+ -e 's:make:$(MAKE):' Makefile || \
+ die "sed Makefile failed"
+}
+
+src_install() {
+ dogamesbin atanks
+ dodir /usr/share/games/atanks
+ cp ${S}/*dat ${D}${DATA_DIR}
+
+ dodoc Changelog INSTRUCTIONS README TODO readme.linux tanks.txt
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ einfo "NOTE: If you had atanks version 0.9.8b or less installed"
+ einfo "remove ~/.atanks-config to take advantage of new features."
+ games_pkg_postinst
+}