summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/jam/jam-2.5.ebuild')
-rw-r--r--dev-util/jam/jam-2.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/jam/jam-2.5.ebuild b/dev-util/jam/jam-2.5.ebuild
new file mode 100644
index 000000000000..3c9236fbce69
--- /dev/null
+++ b/dev-util/jam/jam-2.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/jam/jam-2.5.ebuild,v 1.1 2003/06/16 15:43:36 vapier Exp $
+
+DESCRIPTION="Just Another Make - advanced make replacement"
+SRC_URI="ftp://ftp.perforce.com/pub/jam/${P}.tar"
+HOMEPAGE="http://www.perforce.com/jam/jam.html"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+DEPEND="dev-util/yacc"
+
+src_compile() {
+ # The bootstrap makefile assumes ${S} is in the path
+ env PATH="${PATH}:${S}" make CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ BINDIR="${D}/usr/bin" ./jam0 install || die
+ dohtml Jam.html Jambase.html Jamfile.html
+ dodoc README RELNOTES Porting
+}