summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/dvipost/dvipost-1.1.ebuild')
-rw-r--r--dev-tex/dvipost/dvipost-1.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-tex/dvipost/dvipost-1.1.ebuild b/dev-tex/dvipost/dvipost-1.1.ebuild
new file mode 100644
index 000000000000..f71e43480f1f
--- /dev/null
+++ b/dev-tex/dvipost/dvipost-1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/dvipost/dvipost-1.1.ebuild,v 1.1 2007/07/27 04:42:00 aballier Exp $
+
+inherit latex-package eutils toolchain-funcs
+
+DESCRIPTION="post processor for dvi files"
+HOMEPAGE="http://efeu.cybertec.at/index_en.html"
+SRC_URI="http://efeu.cybertec.at/dist/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/tetex"
+
+src_compile() {
+ local myconf=""
+ local flags="${CFLAGS}"
+ tc-export CC
+
+ econf || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin dvipost
+ dosym /usr/bin/dvipost /usr/bin/pptex
+ dosym /usr/bin/dvipost /usr/bin/pplatex
+
+ insinto /usr/share/texmf/tex/latex/misc/
+ insopts -m0644
+ doins dvipost.sty
+
+ dodoc dvipost.doc CHANGELOG NOTES README
+ dohtml dvipost.html
+ newman ${S}/dvipost.man dvipost.1
+}