summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-aserve/cl-aserve-1.2.42.20050220.ebuild')
-rw-r--r--dev-lisp/cl-aserve/cl-aserve-1.2.42.20050220.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-lisp/cl-aserve/cl-aserve-1.2.42.20050220.ebuild b/dev-lisp/cl-aserve/cl-aserve-1.2.42.20050220.ebuild
new file mode 100644
index 000000000000..58dbb4826bf9
--- /dev/null
+++ b/dev-lisp/cl-aserve/cl-aserve-1.2.42.20050220.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-aserve/cl-aserve-1.2.42.20050220.ebuild,v 1.1 2005/02/24 06:49:14 mkennedy Exp $
+
+inherit common-lisp eutils
+
+MY_PV=${PV:0:6}
+CVS_PV=${PV:7:4}.${PV:11:2}.${PV:13}
+
+DESCRIPTION="A portable version of AllegroServe which is a web application server for Common Lisp programs."
+HOMEPAGE="http://portableaserve.sourceforge.net/
+ http://packages.debian.org/unstable/web/cl-aserve.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-portable-aserve/cl-portable-aserve_${MY_PV}+cvs.${CVS_PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+DEPEND="=dev-lisp/cl-acl-compat-${PV}*
+ =dev-lisp/cl-htmlgen-${PV}*"
+
+CLPACKAGE=aserve
+
+S=${WORKDIR}/cl-portable-aserve-${MY_PV}+cvs.${CVS_PV}
+
+src_install() {
+ common-lisp-install aserve/*.cl aserve/*.asd
+ common-lisp-system-symlink
+ dodoc ChangeLog README README.cmucl INSTALL.lisp logical-hostnames.lisp
+ docinto examples
+ dodoc contrib/*.lisp
+}