summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/tre/tre-0.6.8.ebuild')
-rw-r--r--dev-libs/tre/tre-0.6.8.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/tre/tre-0.6.8.ebuild b/dev-libs/tre/tre-0.6.8.ebuild
new file mode 100644
index 000000000000..27cff146bf9f
--- /dev/null
+++ b/dev-libs/tre/tre-0.6.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/tre/tre-0.6.8.ebuild,v 1.1 2004/06/08 00:18:11 dragonheart Exp $
+
+IUSE="nls static"
+
+DESCRIPTION="Lightweight, robust, and efficient POSIX compliant regexp matching library."
+HOMEPAGE="http://laurikari.net/tre/index.html"
+SRC_URI="http://laurikari.net/tre/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="virtual/glibc
+ sys-apps/gawk
+ sys-apps/grep
+ sys-apps/sed
+ sys-devel/gettext
+ sys-devel/libtool
+ sys-devel/gcc
+ dev-util/pkgconfig"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ # Build TRE library.
+ cd ${S}
+ econf \
+ `use_enable nls` \
+ `use_enable static` \
+ --enable-agrep \
+ --enable-system-abi \
+ --disable-profile \
+ --disable-debug || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ cd ${S}
+ dohtml doc/tre-api.html doc/tre-syntax.html
+}
+
+
+pkg_postinst() {
+ ewarn "Both app-misc/glimpse and this package provide agrep."
+ ewarn "they seem to be similar but just to let you know."
+ ewarn "If this causes a problem please do a bug report"
+ ewarn "bugs.gentoo.org."
+}