summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/gtkspell/gtkspell-2.0.16.ebuild')
-rw-r--r--app-text/gtkspell/gtkspell-2.0.16.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-text/gtkspell/gtkspell-2.0.16.ebuild b/app-text/gtkspell/gtkspell-2.0.16.ebuild
new file mode 100644
index 000000000000..aea730cbb650
--- /dev/null
+++ b/app-text/gtkspell/gtkspell-2.0.16.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/gtkspell-2.0.16.ebuild,v 1.1 2010/03/01 20:26:28 eva Exp $
+
+EAPI="2"
+
+DESCRIPTION="Spell checking widget for GTK2"
+HOMEPAGE="http://gtkspell.sourceforge.net/"
+# gtkspell doesn't use sourceforge mirroring system it seems.
+SRC_URI="http://${PN}.sourceforge.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/gtk+-2
+ >=app-text/enchant-1.1.6"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0
+ doc? (
+ >=dev-util/gtk-doc-1
+ =app-text/docbook-xml-dtd-4.2* )"
+
+src_prepare() {
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
+ || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable doc gtk-doc)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ # not installing NEWS, it's empty
+ dodoc AUTHORS ChangeLog README || die "dodoc failed"
+}