summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/aspell/aspell-0.60.3.ebuild')
-rw-r--r--app-text/aspell/aspell-0.60.3.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/app-text/aspell/aspell-0.60.3.ebuild b/app-text/aspell/aspell-0.60.3.ebuild
deleted file mode 100644
index 83ac68a10325..000000000000
--- a/app-text/aspell/aspell-0.60.3.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.60.3.ebuild,v 1.6 2007/03/04 07:27:33 genone Exp $
-
-inherit libtool eutils flag-o-matic
-
-DESCRIPTION="A spell checker replacement for ispell"
-HOMEPAGE="http://aspell.net/"
-SRC_URI="mirror://gnu/aspell/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sh ~sparc ~x86"
-IUSE="gpm"
-
-DEPEND=">=sys-libs/ncurses-5.2
- gpm? ( sys-libs/gpm )"
-
-src_unpack() {
- unpack ${A}; cd ${S}
- epatch ${FILESDIR}/${P}-templateinstantiations.patch
-}
-
-src_compile() {
- [ "${ARCH}" == "ppc" ] && append-flags -O2 -fsigned-char
- use gpm && append-ldflags -lgpm
- filter-flags -fno-rtti
- filter-flags -fvisibility=hidden #77109
- elibtoolize --reverse-deps
-
- econf \
- --disable-static \
- --sysconfdir=/etc/aspell \
- --enable-docdir=/usr/share/doc/${PF} || die
-
- emake || die
-}
-
-src_install() {
- dodoc README* TODO
-
- make DESTDIR="${D}" install || die
- mv ${D}/usr/share/doc/${PF}/man-html ${D}/usr/share/doc/${PF}/html
- mv ${D}/usr/share/doc/${PF}/man-text ${D}/usr/share/doc/${PF}/text
-
- # install ispell/aspell compatibility scripts
- exeinto /usr/bin
- newexe scripts/ispell ispell-aspell
- newexe scripts/spell spell-aspell
-
- cd examples
- make clean || die
- docinto examples
- dodoc ${S}/examples/*
-}
-
-pkg_postinst() {
- elog "You will need to install a dictionary now. Please choose an"
- elog "aspell-<LANG> dictionary from the app-dicts category"
- elog "After installing an aspell dictionary for your language(s),"
- elog "You may use the aspell-import utility to import your personal"
- elog "dictionaries from ispell, pspell and the older aspell"
-
- ewarn ""
- ewarn "Please re-emerge ALL your aspell-LANG dictionaries"
- ewarn ""
- ebeep 5
-}