summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/libreoffice/libreoffice-3.4.2.2.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-3.4.2.2.ebuild40
1 files changed, 27 insertions, 13 deletions
diff --git a/app-office/libreoffice/libreoffice-3.4.2.2.ebuild b/app-office/libreoffice/libreoffice-3.4.2.2.ebuild
index b258ef60480c..1091dbe2ba06 100644
--- a/app-office/libreoffice/libreoffice-3.4.2.2.ebuild
+++ b/app-office/libreoffice/libreoffice-3.4.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.2.2.ebuild,v 1.15 2011/07/26 16:20:59 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.2.2.ebuild,v 1.16 2011/07/26 18:20:01 scarabeus Exp $
EAPI=3
@@ -10,14 +10,15 @@ CMAKE_REQUIRED="never"
PYTHON_DEPEND="2"
PYTHON_USE_WITH="threads,xml"
+DEV_URI="http://download.documentfoundation.org/libreoffice/src"
+EXT_URI="http://ooo.itc.hu/oxygenoffice/download/libreoffice"
+ADDONS_URI="http://dev-www.libreoffice.org/src/"
+
inherit base autotools check-reqs eutils java-pkg-opt-2 kde4-base pax-utils prefix python multilib toolchain-funcs flag-o-matic
DESCRIPTION="LibreOffice, a full office productivity suite."
HOMEPAGE="http://www.libreoffice.org"
-DEV_URI="http://download.documentfoundation.org/libreoffice/src"
-EXT_URI="http://ooo.itc.hu/oxygenoffice/download/libreoffice"
-ADDONS_URI="http://dev-www.libreoffice.org/src/"
-SRC_URI="odk? ( java? ( http://tools.openoffice.org/unowinreg_prebuild/680/unowinreg.dll ) )"
+SRC_URI="branding? ( http://dev.gentooexperimental.org/~scarabeus/${PN}-branding-gentoo-0.1.tar.xz )"
# Shiny split sources with so many packages...
MODULES="artwork base calc components extensions extras filters help
@@ -96,8 +97,9 @@ unset ADDONS_URI
unset EXT_URI
unset ADDONS_SRC
-IUSE="binfilter cups custom-cflags dbus debug eds gnome gstreamer gtk kde ldap
-mysql nsplugin odk offlinehelp opengl python templates test +vba webdav"
+IUSE="binfilter +branding cups custom-cflags dbus debug eds gnome gstreamer gtk
+kde ldap mysql nsplugin odk offlinehelp opengl python templates test +vba
+webdav"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
@@ -281,6 +283,10 @@ pkg_setup() {
src_unpack() {
local mod dest tmplfile tmplname
+ if use branding; then
+ unpack "${PN}-branding-gentoo-0.1.tar.xz"
+ fi
+
#first the bootstrap files
unpack "${PN}-bootstrap-${PV}.tar.bz2"
@@ -355,9 +361,8 @@ src_configure() {
--enable-ext-presenter-minimizer
"
- # Things that do not have gentoo packages
# hsqldb: requires just 1.8.0 not 1.8.1 which we don't ship at all
- # we should use in-system dmake: so far fails
+ # dmake: not worth of splitting out
internal_libs+="
--without-system-hsqldb
"
@@ -389,9 +394,12 @@ src_configure() {
fi
fi
- # TODO: create gentoo branding on the about/intro screens
- # --with-about-bitmap="${FILESDIR}/gentoo-about.png"
- # --with-intro-bitmap="${FILESDIR}/gentoo-intro.png"
+ if use branding; then
+ extensions+="
+ --with-about-bitmap="${WORKDIR}/branding-about.png"
+ --with-intro-bitmap="${WORKDIR}/branding-intro.png"
+ "
+ fi
# system headers/libs/...: enforce using system packages
# only expections are mozilla and odbc/sane/xrender-header(s).
@@ -491,7 +499,8 @@ src_configure() {
$(use_with offlinehelp helppack-integration) \
$(use_with templates sun-templates) \
${internal_libs} \
- ${java_opts}
+ ${java_opts} \
+ ${extensions}
}
src_compile() {
@@ -501,6 +510,11 @@ src_compile() {
src_install() {
# This is not Makefile so no buildserver
make DESTDIR="${D}" distro-pack-install || die
+
+ if use branding; then
+ insinto /usr/$(get_libdir)/${PN}/program
+ newins "${WORKDIR}/branding-sofficerc" sofficerc || die
+ fi
}
pkg_preinst() {