summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/psgml/psgml-1.2.5-r1.ebuild')
-rw-r--r--app-emacs/psgml/psgml-1.2.5-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/psgml/psgml-1.2.5-r1.ebuild b/app-emacs/psgml/psgml-1.2.5-r1.ebuild
new file mode 100644
index 000000000000..ee52087c054c
--- /dev/null
+++ b/app-emacs/psgml/psgml-1.2.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/psgml/psgml-1.2.5-r1.ebuild,v 1.1 2003/10/23 08:52:48 obz Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="PSGML is a GNU Emacs Major Mode for editing SGML and XML coded documents."
+HOMEPAGE="http://sourceforge.net/projects/psgml/"
+SRC_URI="mirror://sourceforge/psgml/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs
+ app-text/openjade"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50psgml-gentoo.el
+
+src_compile() {
+ emacs --batch --no-site-file --no-init-file \
+ --load psgml-maint.el -f psgml-compile-files || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc *.map
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ dodoc ChangeLog INSTALL README.psgml psgml.ps
+ doinfo psgml-api.info psgml.info
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}