summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/camlidl/ChangeLog5
-rw-r--r--dev-ml/camlidl/camlidl-1.05.ebuild21
-rw-r--r--dev-ml/cryptokit/ChangeLog7
-rw-r--r--dev-ml/cryptokit/cryptokit-1.3.ebuild25
-rw-r--r--dev-ml/ocaml-expat/ChangeLog8
-rw-r--r--dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild24
-rw-r--r--dev-ml/ocaml-mysql/ChangeLog8
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.0.4.ebuild27
-rw-r--r--dev-ml/ocamlgraph/ChangeLog8
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-0.99b.ebuild33
-rw-r--r--dev-ml/ocamlnet/ChangeLog8
-rw-r--r--dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild30
12 files changed, 77 insertions, 127 deletions
diff --git a/dev-ml/camlidl/ChangeLog b/dev-ml/camlidl/ChangeLog
index 5c85f7fa7997..fcfa39ed612f 100644
--- a/dev-ml/camlidl/ChangeLog
+++ b/dev-ml/camlidl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/camlidl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/ChangeLog,v 1.4 2009/04/15 04:55:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/ChangeLog,v 1.5 2009/09/28 16:45:42 betelgeuse Exp $
+
+ 28 Sep 2009; Petteri Räty <betelgeuse@gentoo.org> camlidl-1.05.ebuild:
+ Migrate to EAPI 2 in order to nuke built_with_use.
15 Apr 2009; Alexis Ballier <aballier@gentoo.org> +files/includes.patch,
+files/tests.patch, camlidl-1.05.ebuild:
diff --git a/dev-ml/camlidl/camlidl-1.05.ebuild b/dev-ml/camlidl/camlidl-1.05.ebuild
index f11cbf52094b..970a6aa4266a 100644
--- a/dev-ml/camlidl/camlidl-1.05.ebuild
+++ b/dev-ml/camlidl/camlidl-1.05.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/camlidl-1.05.ebuild,v 1.3 2009/04/15 04:55:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/camlidl-1.05.ebuild,v 1.4 2009/09/28 16:45:42 betelgeuse Exp $
+
+EAPI="2"
inherit eutils toolchain-funcs
@@ -11,20 +13,9 @@ LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64"
IUSE=""
-DEPEND=">=dev-lang/ocaml-3.07"
-
-pkg_setup() {
- if ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "${PN} needs to be built with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/tests.patch"
epatch "${FILESDIR}/includes.patch"
}
@@ -54,5 +45,5 @@ src_install() {
emake BINDIR="${D}/usr/bin" OCAMLLIB="${D}${libdir}" install || die
# Documentation
- dodoc README Changes
+ dodoc README Changes || die
}
diff --git a/dev-ml/cryptokit/ChangeLog b/dev-ml/cryptokit/ChangeLog
index eff5f7783997..89869696aebe 100644
--- a/dev-ml/cryptokit/ChangeLog
+++ b/dev-ml/cryptokit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/cryptokit
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/cryptokit/ChangeLog,v 1.3 2008/09/25 12:22:51 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/cryptokit/ChangeLog,v 1.4 2009/09/28 16:47:43 betelgeuse Exp $
+
+ 28 Sep 2009; Petteri Räty <betelgeuse@gentoo.org> cryptokit-1.3.ebuild:
+ Migrate to EAPI 2 in order to nuke built_with_use.
25 Sep 2008; Alexis Ballier <aballier@gentoo.org> cryptokit-1.3.ebuild:
keyword ~x86-fbsd
diff --git a/dev-ml/cryptokit/cryptokit-1.3.ebuild b/dev-ml/cryptokit/cryptokit-1.3.ebuild
index 12f9cd477f5c..d72dc6d321a1 100644
--- a/dev-ml/cryptokit/cryptokit-1.3.ebuild
+++ b/dev-ml/cryptokit/cryptokit-1.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/cryptokit/cryptokit-1.3.ebuild,v 1.4 2008/09/25 12:22:51 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/cryptokit/cryptokit-1.3.ebuild,v 1.5 2009/09/28 16:47:43 betelgeuse Exp $
-inherit eutils findlib
+EAPI="2"
-EAPI="1"
+inherit eutils findlib
DESCRIPTION="Cryptographic primitives library for Objective Caml"
HOMEPAGE="http://cristal.inria.fr/~xleroy/software.html"
@@ -14,21 +14,10 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
IUSE="doc +ocamlopt"
-DEPEND=">=dev-lang/ocaml-3.09
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
>=sys-libs/zlib-1.1"
-pkg_setup() {
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
sed -e "s/VERSION/${PV}/" "${FILESDIR}/META" >> META
epatch "${FILESDIR}/${PN}-gentoo.patch"
}
@@ -42,7 +31,7 @@ src_compile() {
src_install() {
findlib_src_install
- dodoc Changes README
+ dodoc Changes README || die
use doc && dohtml doc/*.html doc/*.css
}
diff --git a/dev-ml/ocaml-expat/ChangeLog b/dev-ml/ocaml-expat/ChangeLog
index 9bb9a6c487b7..c8d9aada5a2d 100644
--- a/dev-ml/ocaml-expat/ChangeLog
+++ b/dev-ml/ocaml-expat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/ocaml-expat
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-expat/ChangeLog,v 1.4 2008/07/13 06:56:01 josejx Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-expat/ChangeLog,v 1.5 2009/09/28 16:53:50 betelgeuse Exp $
+
+ 28 Sep 2009; Petteri Räty <betelgeuse@gentoo.org>
+ ocaml-expat-0.9.1.ebuild:
+ Migrate to EAPI 2 in order to nuke built_with_use.
13 Jul 2008; Joseph Jezak <josejx@gentoo.org> ocaml-expat-0.9.1.ebuild:
Marked ~ppc for bug #197363.
diff --git a/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild b/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild
index ed7269011c97..d14debb42c3b 100644
--- a/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild
+++ b/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild,v 1.4 2008/07/13 06:56:01 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild,v 1.5 2009/09/28 16:53:50 betelgeuse Exp $
-EAPI="1"
+EAPI="2"
inherit findlib eutils
@@ -12,7 +12,8 @@ DESCRIPTION="OCaml bindings for expat"
SRC_URI="http://www.xs4all.nl/~mmzeeman/ocaml/${P}.tar.gz"
HOMEPAGE="http://www.xs4all.nl/~mmzeeman/ocaml/"
-RDEPEND="dev-libs/expat"
+RDEPEND="dev-libs/expat
+ >=dev-lang/ocaml-3.10.2[ocamlopt?]"
DEPEND="${RDEPEND}
test? ( dev-ml/ounit )"
@@ -21,18 +22,7 @@ SLOT="0"
LICENSE="MIT"
KEYWORDS="~amd64 ~ppc ~x86"
-pkg_setup() {
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
-src_unpack(){
- unpack ${A}
- cd "${S}"
+src_prepare(){
epatch "${FILESDIR}/${P}-test.patch"
}
@@ -57,5 +47,5 @@ src_install() {
if use doc ; then
dohtml -r doc/html/*
fi
- dodoc README
+ dodoc README || die
}
diff --git a/dev-ml/ocaml-mysql/ChangeLog b/dev-ml/ocaml-mysql/ChangeLog
index 6e2f98b497e6..5714e58b36c0 100644
--- a/dev-ml/ocaml-mysql/ChangeLog
+++ b/dev-ml/ocaml-mysql/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/ocaml-mysql
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ChangeLog,v 1.9 2008/04/20 14:24:21 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ChangeLog,v 1.10 2009/09/28 16:54:47 betelgeuse Exp $
+
+ 28 Sep 2009; Petteri Räty <betelgeuse@gentoo.org>
+ ocaml-mysql-1.0.4.ebuild:
+ Migrate to EAPI 2 in order to nuke built_with_use.
20 Apr 2008; Alexis Ballier <aballier@gentoo.org>
-files/ocaml-mysql-1.0.3-shtool.patch, -ocaml-mysql-1.0.3-r1.ebuild:
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.0.4.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.0.4.ebuild
index ca8d68648b0b..7cc21366a0e8 100644
--- a/dev-ml/ocaml-mysql/ocaml-mysql-1.0.4.ebuild
+++ b/dev-ml/ocaml-mysql/ocaml-mysql-1.0.4.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ocaml-mysql-1.0.4.ebuild,v 1.3 2008/04/20 14:13:50 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ocaml-mysql-1.0.4.ebuild,v 1.4 2009/09/28 16:54:47 betelgeuse Exp $
-inherit findlib eutils
+EAPI="2"
-EAPI="1"
+inherit findlib eutils
IUSE="doc +ocamlopt"
@@ -12,7 +12,7 @@ DESCRIPTION="A package for ocaml that provides access to mysql databases."
SRC_URI="http://raevnos.pennmush.org/code/${PN}/${P}.tar.gz"
HOMEPAGE="http://raevnos.pennmush.org/code/ocaml-mysql/index.html"
-DEPEND=">=dev-lang/ocaml-3.06
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
>=virtual/mysql-4.0"
RDEPEND="$DEPEND"
@@ -21,26 +21,13 @@ SLOT="0"
LICENSE="LGPL-2"
KEYWORDS="~amd64 ppc x86"
-pkg_setup() {
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}/${PN}-1.0.3-head.patch"
epatch "${FILESDIR}/${PN}-1.0.3-shtool-r1.patch"
}
src_compile()
{
- econf
emake all || die "make failed"
if use ocamlopt; then
emake opt || die "make opt failed"
@@ -53,5 +40,5 @@ src_install()
emake install || die "make install failed"
use doc && dohtml -r doc/html/*
- dodoc CHANGES README VERSION
+ dodoc CHANGES README VERSION || die
}
diff --git a/dev-ml/ocamlgraph/ChangeLog b/dev-ml/ocamlgraph/ChangeLog
index c49b28c7d5ab..549b2018e671 100644
--- a/dev-ml/ocamlgraph/ChangeLog
+++ b/dev-ml/ocamlgraph/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/ocamlgraph
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ChangeLog,v 1.11 2008/04/06 19:42:21 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ChangeLog,v 1.12 2009/09/28 16:51:57 betelgeuse Exp $
+
+ 28 Sep 2009; Petteri Räty <betelgeuse@gentoo.org>
+ ocamlgraph-0.99b.ebuild:
+ Migrate to EAPI 2 in order to nuke built_with_use.
06 Apr 2008; Alexis Ballier <aballier@gentoo.org> -ocamlgraph-0.81.ebuild:
remove old
diff --git a/dev-ml/ocamlgraph/ocamlgraph-0.99b.ebuild b/dev-ml/ocamlgraph/ocamlgraph-0.99b.ebuild
index d565c17daafe..3f445813d5d0 100644
--- a/dev-ml/ocamlgraph/ocamlgraph-0.99b.ebuild
+++ b/dev-ml/ocamlgraph/ocamlgraph-0.99b.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ocamlgraph-0.99b.ebuild,v 1.4 2008/04/06 19:33:03 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ocamlgraph-0.99b.ebuild,v 1.5 2009/09/28 16:51:57 betelgeuse Exp $
-inherit findlib eutils
+EAPI="2"
-EAPI="1"
+inherit findlib eutils
DESCRIPTION="O'Caml Graph library"
HOMEPAGE="http://www.lri.fr/~filliatr/ocamlgraph/"
@@ -12,33 +12,16 @@ SRC_URI="http://www.lri.fr/~filliatr/ftp/ocamlgraph/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
-DEPEND=">=dev-lang/ocaml-3.08
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
doc? ( dev-tex/hevea dev-ml/ocamlweb )
- gtk? ( dev-ml/lablgtk )"
+ gtk? ( dev-ml/lablgtk[gnomecanvas,ocamlopt?] )"
IUSE="doc examples gtk +ocamlopt"
-ocamlgraph_need_use() {
- if ! built_with_use --missing true $1 $2; then
- eerror "In order to build ${PN} with your useflags you first need to build $1 with $2 useflag"
- die "Please install $1 with $2 useflag"
- fi
-}
-
-pkg_setup() {
- use ocamlopt && ocamlgraph_need_use 'dev-lang/ocaml' ocamlopt
- use gtk && ocamlgraph_need_use 'dev-ml/lablgtk' gnomecanvas
- use ocamlopt && use gtk && ocamlgraph_need_use 'dev-ml/lablgtk' ocamlopt
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}/${P}-installfindlib.patch"
}
src_compile() {
- econf
emake -j1 || die "failed to build"
if use doc; then
@@ -60,7 +43,7 @@ src_install() {
newbin editor/editor.byte ocamlgraph_editor || die "failed to install ocamlgraph_editor"
fi
fi
- dodoc README CREDITS FAQ CHANGES
+ dodoc README CREDITS FAQ CHANGES || die
if use doc; then
dohtml doc/*
fi
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index 96866bd33726..52911f2405a5 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/ocamlnet
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.37 2008/09/25 12:20:24 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.38 2009/09/28 16:43:22 betelgeuse Exp $
+
+ 28 Sep 2009; Petteri Räty <betelgeuse@gentoo.org>
+ ocamlnet-2.2.9-r1.ebuild:
+ Migrate to EAPI 2 in order to nuke built_with_use.
25 Sep 2008; Alexis Ballier <aballier@gentoo.org>
ocamlnet-2.2.9-r1.ebuild:
diff --git a/dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild b/dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild
index e5cece374f84..2a12e615270f 100644
--- a/dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild
+++ b/dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild,v 1.10 2008/09/25 12:20:24 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-2.2.9-r1.ebuild,v 1.11 2009/09/28 16:43:22 betelgeuse Exp $
-inherit eutils findlib
+EAPI="2"
-EAPI="1"
+inherit eutils findlib
DESCRIPTION="Modules for OCaml application-level Internet protocols"
HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
@@ -22,26 +22,12 @@ RESTRICT="installsources"
DEPEND=">=dev-ml/findlib-1.0
>=dev-ml/pcre-ocaml-5
>=dev-ml/camlp5-5.05
+ >=dev-lang/ocaml-3.10.2[tk?,ocamlopt?]
gtk? ( >=dev-ml/lablgtk-2 )
ssl? ( dev-ml/ocaml-ssl )"
RDEPEND="${DEPEND}"
-pkg_setup() {
- if use tk && ! built_with_use 'dev-lang/ocaml' tk ;
- then die "If you want to enable tcl/tk, you need to rebuild dev-lang/ocaml with the 'tk' USE flag";
- fi
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}/build_w_camlp5.dpatch"
epatch "${FILESDIR}/${P}-glibc28.patch"
}
@@ -62,7 +48,7 @@ ocamlnet_use_enable() {
fi
}
-src_compile() {
+src_configure() {
./configure \
-bindir /usr/bin \
-datadir /usr/share/${PN} \
@@ -71,7 +57,9 @@ src_compile() {
$(ocamlnet_use_enable tk tcl) \
$(ocamlnet_use_with httpd nethttpd) \
|| die "Error : econf failed!"
+}
+src_compile() {
emake -j1 all || die "make failed"
if use ocamlopt; then
emake -j1 opt || die "make failed"