summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/raptor/ChangeLog9
-rw-r--r--media-libs/raptor/Manifest22
-rw-r--r--media-libs/raptor/files/digest-raptor-1.4.71
-rw-r--r--media-libs/raptor/raptor-1.4.7.ebuild75
4 files changed, 100 insertions, 7 deletions
diff --git a/media-libs/raptor/ChangeLog b/media-libs/raptor/ChangeLog
index c643bddbfd83..94f55bf3ffcb 100644
--- a/media-libs/raptor/ChangeLog
+++ b/media-libs/raptor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/raptor
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.24 2005/04/19 08:18:10 kloeri Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.25 2005/10/18 00:27:48 vapier Exp $
+
+*raptor-1.4.7 (18 Oct 2005)
+
+ 18 Oct 2005; Mike Frysinger <vapier@gentoo.org> +raptor-1.4.7.ebuild:
+ Version bump.
19 Apr 2005; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove retired developer from metadata.xml.
diff --git a/media-libs/raptor/Manifest b/media-libs/raptor/Manifest
index a0a633924a86..49dba70101b1 100644
--- a/media-libs/raptor/Manifest
+++ b/media-libs/raptor/Manifest
@@ -1,8 +1,20 @@
-MD5 188b043787e84973de45f328fbfe99af ChangeLog 2840
-MD5 afe69650affe0acb8179b1e62866cf4b raptor-1.4.5.ebuild 2183
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 35b0a876bf75e6c20cdfcbe61e435486 ChangeLog 2958
+MD5 feb9d1aa2b9359aefd32236c42748615 files/digest-raptor-1.2.0 64
+MD5 d5368b0ed0013f29758afc9a12bd4007 files/digest-raptor-1.4.2 64
+MD5 1bdb97a56fbd4ed14588121781fad850 files/digest-raptor-1.4.5 64
+MD5 a9760c67971a37403703a4eaaec19d21 files/digest-raptor-1.4.7 65
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
MD5 fea2b22a7184775713570221f24078c3 raptor-1.2.0.ebuild 2203
MD5 fbaed81e4d8f4cde95594e090c048339 raptor-1.4.2.ebuild 2123
-MD5 d5368b0ed0013f29758afc9a12bd4007 files/digest-raptor-1.4.2 64
-MD5 1bdb97a56fbd4ed14588121781fad850 files/digest-raptor-1.4.5 64
-MD5 feb9d1aa2b9359aefd32236c42748615 files/digest-raptor-1.2.0 64
+MD5 afe69650affe0acb8179b1e62866cf4b raptor-1.4.5.ebuild 2183
+MD5 ba987cf7a6925c74b87947977e62e993 raptor-1.4.7.ebuild 2193
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDVEIUgIKl8Uu19MoRAtDTAJ9DeSBm1wJ5pmwJFlCHQ4sPRgJQFgCfUK3M
+qJaQ3rJg3rmdDVYyjFdQf80=
+=+Zbr
+-----END PGP SIGNATURE-----
diff --git a/media-libs/raptor/files/digest-raptor-1.4.7 b/media-libs/raptor/files/digest-raptor-1.4.7
new file mode 100644
index 000000000000..a718f811144a
--- /dev/null
+++ b/media-libs/raptor/files/digest-raptor-1.4.7
@@ -0,0 +1 @@
+MD5 f8e251f5183307ab50041c858117370f raptor-1.4.7.tar.gz 1043999
diff --git a/media-libs/raptor/raptor-1.4.7.ebuild b/media-libs/raptor/raptor-1.4.7.ebuild
new file mode 100644
index 000000000000..4c3b03a05b02
--- /dev/null
+++ b/media-libs/raptor/raptor-1.4.7.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/raptor-1.4.7.ebuild,v 1.1 2005/10/18 00:27:48 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="The RDF Parser Toolkit"
+HOMEPAGE="http://librdf.org/raptor/"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="LGPL-2 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~ppc-macos ~sparc ~x86"
+IUSE="curl xml2 gnome ssl"
+
+DEPEND="virtual/libc
+ gnome? ( >=dev-libs/glib-2.2.1 dev-util/pkgconfig )
+ xml2? ( >=dev-libs/libxml2-2.4.0 )
+ !xml2? ( dev-libs/expat )
+ ssl? ( dev-libs/openssl )
+ curl? ( net-misc/curl )"
+RDEPEND="virtual/libc
+ gnome? ( >=dev-libs/glib-2.2.1 )
+ xml2? ( >=dev-libs/libxml2-2.4.0 )
+ !xml2? ( dev-libs/expat )
+ ssl? ( dev-libs/openssl )
+ curl? ( net-misc/curl )"
+
+# compilation with libwww currently breaks and for using libfetch I didn't find the right USE flag
+#IUSE="curl xml2 libwww gnome"
+#DEPEND="virtual/libc
+# gnome? ( >=dev-libs/glib-2.2.1 dev-util/pkgconfig )
+# xml2? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
+# ssl? ( dev-libs/openssl )
+# curl? ( net-misc/curl ) : ( !xml2? ( libwww? ( net-libs/libwww ) ) )
+# "
+#RDEPEND="virtual/libc
+# gnome? ( >=dev-libs/glib-2.2.1 )
+# xml2? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
+# ssl? ( dev-libs/openssl )
+# curl? ( net-misc/curl ) : ( !xml2? ( libwww? ( net-libs/libwww ) ) )"
+
+src_unpack() {
+ unpack ${A}
+ epunt_cxx
+}
+
+src_compile() {
+ local myraptorconf=""
+
+ use xml2 \
+ && myraptorconf="${myraptorconf} --with-xml-parser=libxml" \
+ || myraptorconf="${myraptorconf} --with-xml-parser=expat"
+
+ if use curl ; then
+ myraptorconf="${myraptorconf} --with-www=curl"
+ elif use xml2 ; then
+ myraptorconf="${myraptorconf} --with-www=xml"
+# elif use libwww ;
+# myraptorconf="${myraptorconf} --with-www=libwww"
+ else
+ myraptorconf="${myraptorconf} --with-www=none"
+ fi
+ econf \
+ $(use_enable gnome nfc-check) \
+ ${myraptorconf} \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+ dohtml INSTALL.html NEWS.html README.html
+}