summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/rsync/files/digest-rsync-2.5.01
-rw-r--r--net-misc/rsync/rsync-2.5.0.ebuild44
-rw-r--r--profiles/package.mask2
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.16-r1.ebuild23
4 files changed, 59 insertions, 11 deletions
diff --git a/net-misc/rsync/files/digest-rsync-2.5.0 b/net-misc/rsync/files/digest-rsync-2.5.0
new file mode 100644
index 000000000000..4d6e61608152
--- /dev/null
+++ b/net-misc/rsync/files/digest-rsync-2.5.0
@@ -0,0 +1 @@
+MD5 57e1a945afbb2e63f58919a7de9c6885 rsync-2.5.0.tar.gz 442368
diff --git a/net-misc/rsync/rsync-2.5.0.ebuild b/net-misc/rsync/rsync-2.5.0.ebuild
new file mode 100644
index 000000000000..3e1610ba7df3
--- /dev/null
+++ b/net-misc/rsync/rsync-2.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.5.0.ebuild,v 1.1 2001/12/15 15:34:38 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="File transfer program to keep remote files into sync"
+SRC_URI="http://rsync.samba.org/ftp/rsync/${P}.tar.gz"
+HOMEPAGE="http://rsync.samba.org"
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+#change confdir to /etc/rsync rather than just /etc (the --sysconfdir configure option doesn't work
+ cp rsync.h rsync.h.orig
+ sed -e 's:RSYNCD_CONF "/etc/rsyncd.conf":RSYNCD_CONF "/etc/rsync/rsyncd.conf":g' rsync.h.orig > rsync.h
+#yes, updating the man page is very important.
+ cp rsyncd.conf.5 rsyncd.conf.5.orig
+ sed -e 's:/etc/rsyncd:/etc/rsync/rsyncd:g' rsyncd.conf.5.orig > rsyncd.conf.5
+}
+
+src_compile() {
+ ./configure --prefix=/usr --host=${CHOST} || die
+ if [ "`use static`" ] ; then
+ emake LDFLAGS="-static" || die
+ else
+ emake || die
+ fi
+}
+
+src_install () {
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
+ if [ -z "`use build`" ]
+ then
+ dodir /etc/rsync
+ dodoc COPYING README
+ else
+ rm -rf ${D}/usr/share
+ fi
+
+}
+
+
diff --git a/profiles/package.mask b/profiles/package.mask
index d8a7700d06bd..548ff0c055e1 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -1,5 +1,5 @@
#still playing with XFS, low latency patches (12/14/2001 - drobbins)
-=sys-kernel/linux-sources-2.4.16-r1
+#=sys-kernel/linux-sources-2.4.16-r1
#incomplete and very dangerous
>=app-office/openoffice-641b
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.16-r1.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.16-r1.ebuild
index eb0321a87c5a..22c1f19b46ce 100644
--- a/sys-kernel/linux-sources/linux-sources-2.4.16-r1.ebuild
+++ b/sys-kernel/linux-sources/linux-sources-2.4.16-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.16-r1.ebuild,v 1.2 2001/12/15 03:26:52 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.16-r1.ebuild,v 1.3 2001/12/15 15:34:38 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
@@ -9,8 +9,8 @@
GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
OKV=${PV}
KV=${OKV}
-S=${WORKDIR}/linux-${PVR}
-S2=${WORKDIR}/linux-${PVR}-extras
+S=${WORKDIR}/linux-${KV}
+S2=${WORKDIR}/linux-${KV}-extras
# Patch versions. We now have a new system. To enable a patch, set the patch version. To disable
# a patch, comment out the patch version and it won't be enabled. In this ebuild, ACPI, low latency
@@ -67,8 +67,8 @@ src_unpack() {
cd ${WORKDIR}
unpack linux-${OKV}.tar.bz2
- mv linux linux-${PVR} || die
- dodir /usr/src/linux-${PVR}-extras
+ mv linux linux-${KV} || die
+ dodir /usr/src/linux-${KV}-extras
if [ "$MOSIX" ]
then
cd ${S2}
@@ -77,8 +77,11 @@ src_unpack() {
cd ${S}
patchorama $PATCHES
echo "Fixing up a single reject..."
- #This is a reject related to both low latency and XFS's kdb modifying the same enum. No biggie.
+ This is a reject related to both low latency and XFS's kdb modifying the same enum. No biggie.
cp ${GFILESDIR}/sysctl.h ${S}/include/linux
+ echo "Removing -xfs extension from the kernel..."
+ cp Makefile Makefile.orig
+ sed -e 's:EXTRAVERSION =-xfs:EXTRAVERSION =:g' Makefile.orig > Makefile
echo "Preparing for compilation..."
#sometimes we have icky kernel symbols; this seems to get rid of them
@@ -124,9 +127,9 @@ src_install() {
dodir /usr/include/asm
cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
fi
- if [ -d ${D}/usr/src/linux-${PVR} ]
+ if [ -d ${D}/usr/src/linux-${KV} ]
then
- cd ${D}/usr/src/linux-${PVR}
+ cd ${D}/usr/src/linux-${KV}
if [ -e .config ]
then
mv .config .config.eg
@@ -151,9 +154,9 @@ pkg_preinst() {
pkg_postinst() {
[ "$PN" = "linux-headers" ] && return
rm -f ${ROOT}/usr/src/linux
- ln -sf linux-${PVR} ${ROOT}/usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
#copy over our .config if one isn't already present
- cd ${ROOT}/usr/src/linux-${PVR}
+ cd ${ROOT}/usr/src/linux-${KV}
if [ "${PN}" = "linux-sources" ] && [ -e .config.eg ] && [ ! -e .config ]
then
cp -a .config.eg .config