summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/glib/glib-2.4.4.ebuild4
-rw-r--r--dev-libs/glib/glib-2.4.5.ebuild4
-rw-r--r--dev-libs/glib/glib-2.4.6.ebuild4
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.2.0.ebuild13
-rw-r--r--dev-libs/libgpg-error/libgpg-error-1.0.ebuild4
-rw-r--r--dev-libs/libksba/libksba-0.9.6.ebuild4
-rw-r--r--dev-libs/libusb/libusb-0.1.8.ebuild9
-rw-r--r--dev-libs/popt/popt-1.7-r1.ebuild4
-rw-r--r--dev-libs/pth/pth-1.4.1.ebuild4
9 files changed, 30 insertions, 20 deletions
diff --git a/dev-libs/glib/glib-2.4.4.ebuild b/dev-libs/glib/glib-2.4.4.ebuild
index b485a36a49eb..c41ee9302e53 100644
--- a/dev-libs/glib/glib-2.4.4.ebuild
+++ b/dev-libs/glib/glib-2.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.4.ebuild,v 1.9 2004/09/16 01:48:51 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.4.ebuild,v 1.10 2004/09/16 01:49:52 pvdabeel Exp $
inherit libtool
@@ -23,6 +23,8 @@ src_compile() {
if use macos; then
glibtoolize
+ elif use ppc-macos; then
+ glibtoolize
else
elibtoolize
fi
diff --git a/dev-libs/glib/glib-2.4.5.ebuild b/dev-libs/glib/glib-2.4.5.ebuild
index 737901da2710..b90922808d21 100644
--- a/dev-libs/glib/glib-2.4.5.ebuild
+++ b/dev-libs/glib/glib-2.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.5.ebuild,v 1.6 2004/09/16 01:48:51 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.5.ebuild,v 1.7 2004/09/16 01:50:38 pvdabeel Exp $
inherit libtool
@@ -23,6 +23,8 @@ src_compile() {
if use macos; then
glibtoolize
+ elif use ppc-macos; then
+ glibtoolize
else
elibtoolize
fi
diff --git a/dev-libs/glib/glib-2.4.6.ebuild b/dev-libs/glib/glib-2.4.6.ebuild
index ea528d0b6f6d..a9b3eb945546 100644
--- a/dev-libs/glib/glib-2.4.6.ebuild
+++ b/dev-libs/glib/glib-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.6.ebuild,v 1.2 2004/09/16 01:48:51 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.6.ebuild,v 1.3 2004/09/16 01:51:13 pvdabeel Exp $
inherit libtool
@@ -23,6 +23,8 @@ src_compile() {
if use macos; then
glibtoolize
+ elif use ppc-macos; then
+ glibtoolize
else
elibtoolize
fi
diff --git a/dev-libs/libgcrypt/libgcrypt-1.2.0.ebuild b/dev-libs/libgcrypt/libgcrypt-1.2.0.ebuild
index 0a874926d4af..15fa236373e3 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.2.0.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.2.0.ebuild,v 1.10 2004/08/19 02:20:57 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.2.0.ebuild,v 1.11 2004/09/16 01:52:20 pvdabeel Exp $
DESCRIPTION="general purpose crypto library based on the code used in GnuPG"
HOMEPAGE="http://www.gnupg.org/"
@@ -8,7 +8,7 @@ SRC_URI="ftp://ftp.gnupg.org/gcrypt/libgcrypt/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~x86 ~amd64 sparc ~mips ~alpha hppa ia64 ~ppc ppc64 macos"
+KEYWORDS="~x86 ~amd64 sparc ~mips ~alpha hppa ia64 ~ppc ppc64 macos ppc-macos"
IUSE="nls"
DEPEND="dev-libs/libgpg-error"
@@ -26,8 +26,11 @@ src_install() {
# backwards compat symlinks
if ! use macos
then
- ln -s libgcrypt.so.11 ${D}/usr/lib/libgcrypt.so.7
- ln -s libgcrypt-pth.so.11 ${D}/usr/lib/libgcrypt-pth.so.7
- ln -s libgcrypt-pthread.so.11 ${D}/usr/lib/libgcrypt-pthread.so.7
+ if ! use ppc-macos
+ then
+ ln -s libgcrypt.so.11 ${D}/usr/lib/libgcrypt.so.7
+ ln -s libgcrypt-pth.so.11 ${D}/usr/lib/libgcrypt-pth.so.7
+ ln -s libgcrypt-pthread.so.11 ${D}/usr/lib/libgcrypt-pthread.so.7
+ fi
fi
}
diff --git a/dev-libs/libgpg-error/libgpg-error-1.0.ebuild b/dev-libs/libgpg-error/libgpg-error-1.0.ebuild
index c6c4b6654c1e..abb45b27c2ca 100644
--- a/dev-libs/libgpg-error/libgpg-error-1.0.ebuild
+++ b/dev-libs/libgpg-error/libgpg-error-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgpg-error/libgpg-error-1.0.ebuild,v 1.4 2004/09/09 18:20:22 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgpg-error/libgpg-error-1.0.ebuild,v 1.5 2004/09/16 01:52:39 pvdabeel Exp $
inherit gnuconfig
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.gnupg.org/gcrypt/${PN}/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS="x86 ~ppc sparc ~mips ~alpha ~hppa ~amd64 ~ia64 ~ppc64 macos"
+KEYWORDS="x86 ~ppc sparc ~mips ~alpha ~hppa ~amd64 ~ia64 ~ppc64 macos ppc-macos"
IUSE="nls"
DEPEND="virtual/libc"
diff --git a/dev-libs/libksba/libksba-0.9.6.ebuild b/dev-libs/libksba/libksba-0.9.6.ebuild
index 360daf55dcf6..be3ff9d62f3c 100644
--- a/dev-libs/libksba/libksba-0.9.6.ebuild
+++ b/dev-libs/libksba/libksba-0.9.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libksba/libksba-0.9.6.ebuild,v 1.7 2004/08/19 02:48:22 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libksba/libksba-0.9.6.ebuild,v 1.8 2004/09/16 01:52:58 pvdabeel Exp $
DESCRIPTION="KSBA makes X.509 certificates and CMS easily accessible to applications"
HOMEPAGE="http://www.gnupg.org/"
@@ -8,7 +8,7 @@ SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/libksba/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64 macos"
+KEYWORDS="~x86 ~ppc ~amd64 macos ppc-macos"
IUSE=""
DEPEND=">=dev-libs/libgpg-error-0.7 dev-libs/libgcrypt"
diff --git a/dev-libs/libusb/libusb-0.1.8.ebuild b/dev-libs/libusb/libusb-0.1.8.ebuild
index c3ed5db415c4..307b42ca77dc 100644
--- a/dev-libs/libusb/libusb-0.1.8.ebuild
+++ b/dev-libs/libusb/libusb-0.1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libusb/libusb-0.1.8.ebuild,v 1.8 2004/08/06 04:09:58 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libusb/libusb-0.1.8.ebuild,v 1.9 2004/09/16 01:54:58 pvdabeel Exp $
inherit eutils
@@ -10,17 +10,18 @@ SRC_URI="mirror://sourceforge/libusb/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64 ~ia64 ppc64 macos"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64 ~ia64 ppc64 macos ppc-macos"
IUSE="debug doc"
DEPEND="sys-devel/libtool
- !macos? ( doc? ( app-text/openjade
- =app-text/docbook-sgml-dtd-3.1-r1 ) )"
+ !macos? ( !ppc-macos? ( doc? ( app-text/openjade
+ =app-text/docbook-sgml-dtd-3.1-r1 ) ) )"
src_unpack(){
unpack ${A}
# needed by libgphoto2, see bug #45889
cd ${S}; epatch ${FILESDIR}/libusb-0.1.8-amd64-fPIC.patch
+ # BUG on macos ARCH is ppc
[ "${ARCH}x" = "macosx" ] && \
( aclocal && autoconf && automake --add-missing )
}
diff --git a/dev-libs/popt/popt-1.7-r1.ebuild b/dev-libs/popt/popt-1.7-r1.ebuild
index 8cb566733cac..d7a0a5f4cb20 100644
--- a/dev-libs/popt/popt-1.7-r1.ebuild
+++ b/dev-libs/popt/popt-1.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/popt-1.7-r1.ebuild,v 1.15 2004/08/19 01:49:22 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/popt-1.7-r1.ebuild,v 1.16 2004/09/16 01:55:18 pvdabeel Exp $
inherit libtool gnuconfig eutils
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390 macos"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390 macos ppc-macos"
IUSE="nls"
DEPEND="nls? ( sys-devel/gettext )"
diff --git a/dev-libs/pth/pth-1.4.1.ebuild b/dev-libs/pth/pth-1.4.1.ebuild
index 2e039205d88d..cc3e2489fa9a 100644
--- a/dev-libs/pth/pth-1.4.1.ebuild
+++ b/dev-libs/pth/pth-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/pth-1.4.1.ebuild,v 1.14 2004/08/25 18:49:45 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/pth-1.4.1.ebuild,v 1.15 2004/09/16 01:55:37 pvdabeel Exp $
inherit gnuconfig
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.gnu.org/gnu/pth/pth-1.4.1.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="x86 ppc sparc amd64 hppa macos"
+KEYWORDS="x86 ppc sparc amd64 hppa macos ppc-macos"
IUSE=""
DEPEND="virtual/libc"