summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-fs/openafs/ChangeLog8
-rw-r--r--net-fs/openafs/files/digest-openafs-1.3.2-r11
-rw-r--r--net-fs/openafs/files/openafs-1.2.5-sunrpc-overflow.patch36
-rw-r--r--net-fs/openafs/files/openafs-1.3.2-sunrpc-overflow.patch78
-rw-r--r--net-fs/openafs/openafs-1.3.2-r1.ebuild92
5 files changed, 28 insertions, 187 deletions
diff --git a/net-fs/openafs/ChangeLog b/net-fs/openafs/ChangeLog
index 35e2cf460c34..1e952030fbe6 100644
--- a/net-fs/openafs/ChangeLog
+++ b/net-fs/openafs/ChangeLog
@@ -1,12 +1,6 @@
# ChangeLog for net-fs/openafs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.4 2002/08/02 22:47:20 aliz Exp $
-
-*openafs-1.3.2-r1 (03 Aug 2002)
-
- 02 Aug 2002; Daniel Ahlberg <aliz@gentoo.org> openafs-1.3.2-r1.ebuild :
-
- Security fix.
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.5 2002/08/02 23:08:25 aliz Exp $
*openafs-1.2.5-r1 (03 Aug 2002)
diff --git a/net-fs/openafs/files/digest-openafs-1.3.2-r1 b/net-fs/openafs/files/digest-openafs-1.3.2-r1
deleted file mode 100644
index 80848ade5cd3..000000000000
--- a/net-fs/openafs/files/digest-openafs-1.3.2-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5057634d9f6c44d5ca9a6dd9fdd84184 openafs-1.3.2-src.tar.gz 12578259
diff --git a/net-fs/openafs/files/openafs-1.2.5-sunrpc-overflow.patch b/net-fs/openafs/files/openafs-1.2.5-sunrpc-overflow.patch
index 1634705da270..554c61e097c8 100644
--- a/net-fs/openafs/files/openafs-1.2.5-sunrpc-overflow.patch
+++ b/net-fs/openafs/files/openafs-1.2.5-sunrpc-overflow.patch
@@ -1,14 +1,5 @@
--- openafs/src/rx/xdr_array.c 2001/08/08 00:03:57 1.4
+++ openafs/src/rx/xdr_array.c 2002/07/31 23:13:49 1.4.2.1
-@@ -29,7 +29,7 @@
- #include <afsconfig.h>
- #include <afs/param.h>
-
--RCSID("$Header: /var/cvsroot/gentoo-x86/net-fs/openafs/files/openafs-1.2.5-sunrpc-overflow.patch,v 1.2 2002/08/02 22:58:23 aliz Exp $");
-+RCSID("$Header: /var/cvsroot/gentoo-x86/net-fs/openafs/files/openafs-1.2.5-sunrpc-overflow.patch,v 1.2 2002/08/02 22:58:23 aliz Exp $");
-
- #ifndef NeXT
-
@@ -84,7 +84,10 @@
register caddr_t target = *addrp;
register u_int c; /* the actual element count */
@@ -34,3 +25,30 @@
RXOBJS = rx_clock.o rx_event.o rx_user.o rx_lwp.o rx.o rx_null.o rx_globals.o \
rx_getaddr.o rx_misc.o rx_packet.o rx_rdwr.o rx_trace.o rx_conncache.o \
+--- openafs/src/rx/xdr.c 2002/06/08 04:47:43 1.3.4.1
++++ openafs/src/rx/xdr.c 2002/07/31 23:13:49 1.3.4.2
+@@ -557,6 +557,8 @@
+ register char *sp = *cpp; /* sp is the actual string pointer */
+ u_int size;
+ u_int nodesize;
++
++ if (maxsize > ((~0) >> 1) - 1) maxsize = ((~0) >> 1) - 1;
+
+ /*
+ * first deal with the length since xdr strings are counted-strings
+
+--- openafs/src/rx/xdr_arrayn.c 2001/08/08 00:03:57 1.4
++++ openafs/src/rx/xdr_arrayn.c 2002/07/31 23:13:49 1.4.2.1
+@@ -89,7 +89,10 @@
+ register caddr_t target = *addrp;
+ register u_int c; /* the actual element count */
+ register bool_t stat = TRUE;
+- register int nodesize;
++ register u_int nodesize;
++
++ i = ((~0) >> 1) / elsize;
++ if (maxsize > i) maxsize = i;
+
+ /* like strings, arrays are really counted arrays */
+ if (! xdr_u_int(xdrs, sizep)) {
+
diff --git a/net-fs/openafs/files/openafs-1.3.2-sunrpc-overflow.patch b/net-fs/openafs/files/openafs-1.3.2-sunrpc-overflow.patch
deleted file mode 100644
index c6f6cbc8fb6e..000000000000
--- a/net-fs/openafs/files/openafs-1.3.2-sunrpc-overflow.patch
+++ /dev/null
@@ -1,78 +0,0 @@
---- openafs/src/rx/xdr_array.c 2001/08/08 00:03:57 1.4
-+++ openafs/src/rx/xdr_array.c 2002/07/31 23:13:28 1.4.6.3
-@@ -29,7 +29,7 @@
- #include <afsconfig.h>
- #include <afs/param.h>
-
--RCSID("$Header: /var/cvsroot/gentoo-x86/net-fs/openafs/files/openafs-1.3.2-sunrpc-overflow.patch,v 1.2 2002/08/02 22:58:23 aliz Exp $");
-+RCSID("$Header: /var/cvsroot/gentoo-x86/net-fs/openafs/files/openafs-1.3.2-sunrpc-overflow.patch,v 1.2 2002/08/02 22:58:23 aliz Exp $");
-
- #ifndef NeXT
-
-@@ -57,10 +57,6 @@
- #endif
- #include "xdr.h"
-
--#ifndef osi_alloc
--char *osi_alloc();
--#endif
--
- #define LASTUNSIGNED ((u_int)0-1)
-
-
-@@ -71,20 +67,25 @@
- * elsize is the size (in bytes) of each element, and elproc is the
- * xdr procedure to call to handle each element of the array.
- */
--bool_t
--xdr_array(xdrs, addrp, sizep, maxsize, elsize, elproc)
-- register XDR *xdrs;
-- caddr_t *addrp; /* array pointer */
-- u_int *sizep; /* number of elements */
-- u_int maxsize; /* max numberof elements */
-- u_int elsize; /* size in bytes of each element */
-- xdrproc_t elproc; /* xdr routine to handle each element */
-+/*
-+ caddr_t *addrp; * array pointer *
-+ u_int *sizep; * number of elements *
-+ u_int maxsize; * max numberof elements *
-+ u_int elsize; * size in bytes of each element *
-+ xdrproc_t elproc; * xdr routine to handle each element *
-+*/
-+
-+bool_t xdr_array(register XDR *xdrs, caddr_t *addrp, u_int *sizep,
-+ u_int maxsize, u_int elsize, xdrproc_t elproc)
- {
- register u_int i;
- register caddr_t target = *addrp;
- register u_int c; /* the actual element count */
- register bool_t stat = TRUE;
-- register int nodesize;
-+ register u_int nodesize;
-+
-+ i = ((~0) >> 1) / elsize;
-+ if (maxsize > i) maxsize = i;
-
- /* like strings, arrays are really counted arrays */
- if (! xdr_u_int(xdrs, sizep)) {
-
---- openafs/src/rx/Makefile.in 2002/07/13 03:26:23 1.10.2.4
-+++ openafs/src/rx/Makefile.in 2002/08/02 02:42:40 1.10.2.5
-@@ -14,13 +14,13 @@
- # Generic xdr objects (or, at least, xdr stuff that's not newly defined for rx).
- # Really the xdr stuff should be in its own directory.
- #
--XDROBJS_common = xdr_rx.o xdr_afsuuid.o
-+XDROBJS_common = xdr.o xdr_array.o xdr_rx.o xdr_afsuuid.o
-
- XDROBJS = xdr_arrayn.o ${XDROBJS_common}
-
--XDROBJS_djgpp = xdr.o xdr_rec.o xdr_stdio.o \
-+XDROBJS_djgpp = xdr_rec.o xdr_stdio.o \
- xdr_float.o xdr_refernce.o xdr_update.o \
-- xdr_array.o xdr_mem.o ${XDROBJS_common}
-+ xdr_mem.o ${XDROBJS_common}
-
- RXOBJS_common = rx_clock.o rx_event.o rx_user.o rx_lwp.o rx.o rx_null.o \
- rx_globals.o rx_getaddr.o rx_misc.o rx_packet.o rx_rdwr.o rx_trace.o \
-
diff --git a/net-fs/openafs/openafs-1.3.2-r1.ebuild b/net-fs/openafs/openafs-1.3.2-r1.ebuild
deleted file mode 100644
index 51e52c4a867e..000000000000
--- a/net-fs/openafs/openafs-1.3.2-r1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# /home/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.1.1.ebuild,v 1.3 2001/08/31 03:23:39 pm Exp
-
-
-S=${WORKDIR}/${P}
-DESCRIPTION="The AFS 3 distributed file system"
-
-SRC_URI="http://www.openafs.org/dl/openafs/${PV}/openafs-${PV}-src.tar.gz"
-HOMEPAGE="http://www.openafs.org/"
-
-SLOT="0"
-LICENSE="IPL-1"
-KEYWORDS="x86 -ppc -sparc -sparc64"
-
-DEPEND=">=sys-libs/ncurses-5.2
- >=sys-libs/pam-0.75"
-
-ARCH=i386_linux24
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- patch -p1 < ${FILESDIR}/${P}-sunrpc-overflow.patch || die
-
- cd ${S}/src/config
- cp Makefile.in Makefile.in.old
- sed -e "s|/usr/lib/libncurses.so|-lncurses|g" \
- Makefile.in.old > Makefile.in
- rm Makefile.in.old
-}
-
-src_compile() {
- ./configure \
- --with-afs-sysname=i386_linux24 \
- --enable-transarc-paths || die
- make || die
- make dest || die
-}
-
-src_install () {
-
-
- # Client
-
- cd ${S}/${ARCH}/dest/root.client/usr/vice
-
- insinto /etc/afs/modload
- doins etc/modload/*
- insinto /etc/afs/C
- doins etc/C/*
-
- insinto /etc/afs
- doins ${FILESDIR}/{ThisCell,CellServDB}
- doins etc/afs.conf
-
- dodir /afs
-
- exeinto /etc/init.d
- newexe ${FILESDIR}/afs.rc.rc6 afs
-
- dosbin etc/afsd
-
- # Client Bin
- cd ${S}/${ARCH}/dest
- exeinto /usr/afsws/bin
- doexe bin/*
-
- exeinto /etc/afs/afsws
- doexe etc/*
-
- cp -a include lib ${D}/usr/afsws
- dosym /usr/afsws/lib/afs/libtermlib.a /usr/afsws/lib/afs/libnull.a
-
- # Server
- cd ${S}/${ARCH}/dest/root.server/usr/afs
- exeinto /usr/afs/bin
- doexe bin/*
-
- dodir /usr/vice
- dosym /etc/afs /usr/vice/etc
- dosym /etc/afs/afsws /usr/afsws/etc
-
- dodoc ${FILESDIR}/README
-}
-
-pkg_postinst () {
- echo ">>> UPDATE CellServDB and ThisCell to your needs !!"
- echo ">>> FOLLOW THE INSTRUCTIONS IN AFS QUICK BEGINNINGS"
- echo ">>> PAGE >45 TO DO INITIAL SERVER SETUP" fi
-}