summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-physics/camfr/Manifest7
-rw-r--r--sci-physics/camfr/camfr-20070717.ebuild71
2 files changed, 3 insertions, 75 deletions
diff --git a/sci-physics/camfr/Manifest b/sci-physics/camfr/Manifest
index c83e020f85a3..dc7dfdd60541 100644
--- a/sci-physics/camfr/Manifest
+++ b/sci-physics/camfr/Manifest
@@ -4,13 +4,12 @@ Hash: SHA1
AUX camfr-20070717-gcc43.patch 391 RMD160 4addf806c2d8ddb5ee5dbd2cc1b02381dbf3f6b8 SHA1 41ef3f6be02d4d6b6bf6d03b4b1f6e9ef0fca3d9 SHA256 50cfc3e04c4774fd0404d044c128cf8346c1762e64808ca77147cb4207729db3
DIST camfr-20070717.tgz 763070 RMD160 4e4237188caecd4dca3980b9cab381479e6382bc SHA1 7838482db8557b365dac51769950d49746397e29 SHA256 f675ba7d58947076c0679c8760c9282e2efc82828bec67de90567fd8a4f135de
EBUILD camfr-20070717-r1.ebuild 1959 RMD160 d450caf8405cd4e6b8a8bcf4619015d113301641 SHA1 132d975a83bf8ebe452018d0607259e090441933 SHA256 42859f3f7c58f3a2ccbfaaca48e6e17bc6dad4bf038dedbe12618466f20451b4
-EBUILD camfr-20070717.ebuild 1850 RMD160 cc57cecffabb7a2e5c0fb42b00c3fb84aae42257 SHA1 57e3487d7af56c52c02188409b475a1f958d09f9 SHA256 21927ad0a1bdad0bb39d97e60c29c6f2720d0e12c57ebe9187188074d8cbfe5d
MISC ChangeLog 2118 RMD160 b757a1e69da0632a0f72146b3e0b1ec4d73b2c8c SHA1 9c525dfb147a1afa5bfe650a482be22ddb9218e5 SHA256 79276dcd23dcc7419da8f4e830a5eee3060f0c84413128111847f870f0ff92c3
MISC metadata.xml 164 RMD160 6e4c63a6f70f174f40277eed39ac05fba4a49566 SHA1 e1af6f2028e69dee3c76e7e85353a144c83d3383 SHA256 9eddaccbdd2f6b3f93213d72782f07518dff1625fd8d63faf61dc97bd328b5e7
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
-iEYEARECAAYFAkhyqzYACgkQ1ycZbhPLE2BLVwCgg/vT7PNh62yKcnyb4pOlQ23O
-UKoAoKFUfyPbVoQ3cgdxEK9YgMuc/ZYd
-=nVg4
+iEYEARECAAYFAkk7qn8ACgkQ1ycZbhPLE2C8mgCfepBUabfwvBeY/S/KZFbALn5h
+Rz4An3A4ogP+frly2lJJt38k2GXgqb71
+=k5eP
-----END PGP SIGNATURE-----
diff --git a/sci-physics/camfr/camfr-20070717.ebuild b/sci-physics/camfr/camfr-20070717.ebuild
deleted file mode 100644
index e576c0fd90c9..000000000000
--- a/sci-physics/camfr/camfr-20070717.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/camfr-20070717.ebuild,v 1.4 2008/07/06 09:56:28 bicatali Exp $
-
-inherit eutils distutils fortran
-
-DESCRIPTION="Full vectorial Maxwell solver based on eigenmode expansion"
-HOMEPAGE="http://camfr.sourceforge.net/"
-SRC_URI="mirror://sourceforge/camfr/${P}.tgz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="sci-libs/scipy
- dev-python/matplotlib
- dev-libs/boost
- dev-libs/blitz
- dev-python/imaging
- virtual/lapack"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- >=dev-util/scons-0.98"
-
-S="${WORKDIR}/${P/-/_}"
-
-pkg_setup() {
- if ! built_with_use dev-lang/python tk || \
- ! built_with_use dev-python/imaging tk ; then
- eerror "Python and/or imaging don't have Tk support enabled."
- eerror "Set the tk USE flag and reinstall python and imaging before continuing."
- die
- fi
- FORTRAN="gfortran g77 ifc"
- fortran_pkg_setup
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc43.patch
- cp machine_cfg.py{.gentoo,} || die
- sed -i -e '/^library_dirs/d' -e '/^libs/d' machine_cfg.py || die
- local lapack_libs=
- for x in $(pkg-config --libs-only-l lapack); do
- lapack_libs="${lapack_libs}, \"${x#-l}\""
- done
- local lapack_libdirs=
- for x in $(pkg-config --libs-only-L lapack); do
- lapack_libdirs="${lapack_libdirs}, \"${x#-L}\""
- done
- cat <<-EOF >> machine_cfg.py
- library_dirs = [${lapack_libdirs#,}]
- libs = ["boost_python", "blitz"${lapack_libs}]
- EOF
-}
-
-src_test() {
- # trick to avoid X in testing (bug #229753)
- echo "backend : Agg" > matplotlibrc
- PYTHONPATH=".:visualisation" ${python} testsuite/camfr_test.py \
- || die "tests failed"
- rm -f matplotlibrc
-}
-
-src_install() {
- distutils_src_install
- dodoc docs/camfr.pdf || die "doc install failed"
-}