summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/sarg/ChangeLog6
-rw-r--r--net-analyzer/sarg/Manifest5
-rw-r--r--net-analyzer/sarg/files/digest-sarg-1.4.1-r22
-rw-r--r--net-analyzer/sarg/files/sarg-1.4.1-2.6.fix.patch63
-rw-r--r--net-analyzer/sarg/sarg-1.4.1-r2.ebuild39
5 files changed, 114 insertions, 1 deletions
diff --git a/net-analyzer/sarg/ChangeLog b/net-analyzer/sarg/ChangeLog
index 74d003b77db3..509f1640b6a6 100644
--- a/net-analyzer/sarg/ChangeLog
+++ b/net-analyzer/sarg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/sarg
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+*sarg-1.4.1-r2 (24 Feb 2004)
+
+ 24 Feb 2004; Jared Hudson <jhhudso@gentoo.org> : Added patch to fix segfault
+ under 2.6.x kernels. Credit goes to Ghislain Bourgeois
+ <ghislain48@hotmail.com> under bug #41834 for this fix.
+
*sarg-1.4.1-r1 (04 Jan 2004)
04 Jan 2004; Jared Hudson <jhhudso@gentoo.org> : Added patch as requested
diff --git a/net-analyzer/sarg/Manifest b/net-analyzer/sarg/Manifest
index a65d3119182e..69629d349ddf 100644
--- a/net-analyzer/sarg/Manifest
+++ b/net-analyzer/sarg/Manifest
@@ -1,8 +1,11 @@
MD5 2c3158204cfb4b9c36b8bc78e8421b16 metadata.xml 223
-MD5 4b9de94fad7ed66b8c0092fe8587c998 ChangeLog 730
+MD5 61544a3566188eae8902321def2dac1b ChangeLog 956
+MD5 3be92711e04a506bbfe747e275ed8465 sarg-1.4.1-r2.ebuild 1000
MD5 35872fcbf62a5813c14263110dfbb524 sarg-1.2.2.ebuild 826
MD5 d28f2ca4b67a859a48ff1864bcbaef3b sarg-1.4.1.ebuild 903
MD5 15f352f86cbd1cb23cd811118b1b3dc9 sarg-1.4.1-r1.ebuild 955
MD5 c1d5675a58b98064b57ce771a2ecd4b8 files/digest-sarg-1.4.1-r1 132
MD5 b60741cb2874bce6ba11ed9ab30de7ac files/digest-sarg-1.2.2 62
MD5 d0d0e64d8851d613b34982597a1d1cee files/digest-sarg-1.4.1 62
+MD5 4ce75e6dba68e51c94d8fb4b47a5ed9f files/sarg-1.4.1-2.6.fix.patch 1556
+MD5 c1d5675a58b98064b57ce771a2ecd4b8 files/digest-sarg-1.4.1-r2 132
diff --git a/net-analyzer/sarg/files/digest-sarg-1.4.1-r2 b/net-analyzer/sarg/files/digest-sarg-1.4.1-r2
new file mode 100644
index 000000000000..0b8bfd6626de
--- /dev/null
+++ b/net-analyzer/sarg/files/digest-sarg-1.4.1-r2
@@ -0,0 +1,2 @@
+MD5 357f8e175746e19dac4a61f4a2ef0aaf sarg-1.4.1.tar.gz 125589
+MD5 4ffb8c39d2fc4261390b3d58c39e588a sarg-1.4.1-index.sort.patch 2034
diff --git a/net-analyzer/sarg/files/sarg-1.4.1-2.6.fix.patch b/net-analyzer/sarg/files/sarg-1.4.1-2.6.fix.patch
new file mode 100644
index 000000000000..5a45ce1c13e0
--- /dev/null
+++ b/net-analyzer/sarg/files/sarg-1.4.1-2.6.fix.patch
@@ -0,0 +1,63 @@
+diff -Naur sarg-1.4.1/html.c sarg_patch/html.c
+--- sarg-1.4.1/html.c 2003-04-25 17:20:55.000000000 +0000
++++ sarg_patch/html.c 2004-02-16 19:31:29.980354640 +0000
+@@ -735,8 +735,8 @@
+
+ }
+
+- (void)closedir( dirp );
+ (void)rewinddir( dirp );
++ (void)closedir( dirp );
+
+ return;
+ }
+diff -Naur sarg-1.4.1/index.c sarg_patch/index.c
+--- sarg-1.4.1/index.c 2004-02-16 20:07:21.382291832 +0000
++++ sarg_patch/index.c 2004-02-16 19:45:35.897755648 +0000
+@@ -107,8 +107,8 @@
+ }
+
+ fclose(fp_tmp);
+- (void)closedir( dirp );
+ (void)rewinddir( dirp );
++ (void)closedir( dirp );
+
+ if(strcmp(IndexSortOrder,"A") == 0)
+ sprintf(html,"sort -n -t';' -k 7,7 %s -o %s", wdir_tmp, wdir_tmp2);
+diff -Naur sarg-1.4.1/lastlog.c sarg_patch/lastlog.c
+--- sarg-1.4.1/lastlog.c 2003-04-25 17:20:55.000000000 +0000
++++ sarg_patch/lastlog.c 2004-02-16 19:38:53.645907224 +0000
+@@ -43,8 +43,8 @@
+ ftot++;
+ }
+
+- (void)closedir( dirp );
+ (void)rewinddir( dirp );
++ (void)closedir( dirp );
+ fclose(fp_ou);
+
+ sprintf(buf,"sort -n -k 1,1 -o %slastlog %s",outdir,temp);
+diff -Naur sarg-1.4.1/sort.c sarg_patch/sort.c
+--- sarg-1.4.1/sort.c 2003-04-25 17:20:55.000000000 +0000
++++ sarg_patch/sort.c 2004-02-16 19:25:12.266775832 +0000
+@@ -84,8 +84,8 @@
+
+ }
+
+- (void)closedir( dirp );
+ (void)rewinddir( dirp );
++ (void)closedir( dirp );
+ return;
+ }
+
+@@ -125,8 +125,8 @@
+ bzero(user, MAXLEN);
+
+ }
+- (void)closedir( dirp );
+ (void)rewinddir( dirp );
+-
++ (void)closedir( dirp );
++
+ return;
+ }
diff --git a/net-analyzer/sarg/sarg-1.4.1-r2.ebuild b/net-analyzer/sarg/sarg-1.4.1-r2.ebuild
new file mode 100644
index 000000000000..f0d0876c7cb3
--- /dev/null
+++ b/net-analyzer/sarg/sarg-1.4.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+DESCRIPTION="Sarg (Squid Analysis Report Generator) is a tool that allows you to view where your users are going to on the Internet."
+HOMEPAGE="http://web.onda.com.br/orso/sarg.html"
+SRC_URI="http://web.onda.com.br/orso/${P}.tar.gz http://web.onda.com.br/orso/patches/sarg-1.4.1-index.sort.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=""
+RDEPEND=">=net-www/squid-2.5.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${DISTDIR}/sarg-1.4.1-index.sort.patch
+ epatch ${FILESDIR}/sarg-1.4.1-2.6.fix.patch
+}
+
+src_compile() {
+ rm -rf config.cache
+ ./configure \
+ --enable-bindir=/usr/bin \
+ --enable-mandir=/usr/man/man1 \
+ --enable-sysconfdir=/etc/sarg || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ dodir /etc/sarg /usr/bin /usr/man/man1
+ make \
+ BINDIR=${D}/usr/bin \
+ MANDIR=${D}/usr/man/man1 \
+ SYSCONFDIR=${D}/etc/sarg \
+ install || die
+}