summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-16 15:22:08 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-16 15:22:08 +0000
commit5dda7ce2d6e3f5810d4ba0a86f7904b53fab0a01 (patch)
treeb8bf0551410dadcc7eb8a458f48eb611a9c0fe6f /xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.1.0-r1.ebuild
parentDrop old leaving last version unaffected by issue #12 and latest masked (diff)
downloadhistorical-5dda7ce2d6e3f5810d4ba0a86f7904b53fab0a01.tar.gz
historical-5dda7ce2d6e3f5810d4ba0a86f7904b53fab0a01.tar.bz2
historical-5dda7ce2d6e3f5810d4ba0a86f7904b53fab0a01.zip
Port from libxfcegui4 to libxfce4ui usin.
Package-Manager: portage-2.2.0_alpha110/cvs/Linux x86_64
Diffstat (limited to 'xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.1.0-r1.ebuild')
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.1.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.1.0-r1.ebuild b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..1e073186a42e
--- /dev/null
+++ b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.1.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.1.0-r1.ebuild,v 1.1 2012/06/16 15:22:08 ssuominen Exp $
+
+EAPI=4
+EAUTORECONF=yes
+inherit multilib xfconf
+
+DESCRIPTION="An mail notification panel plug-in for the Xfce desktop environment"
+HOMEPAGE="http://spuriousinterrupt.org/projects/mailwatch"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug ipv6 ssl"
+
+RDEPEND=">=xfce-base/libxfce4ui-4.8
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/xfce4-panel-4.8
+ ssl? (
+ dev-libs/libgcrypt
+ >=net-libs/gnutls-2
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=(
+ "${FILESDIR}"/${P}-no-ssl.patch
+ "${FILESDIR}"/${P}-libxfce4ui.patch
+ "${FILESDIR}"/${P}-link_to_libgcrypt.patch
+ "${FILESDIR}"/${P}-gnutls-3.patch
+ )
+
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable ssl)
+ $(use_enable ipv6)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}