summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-22 14:58:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-22 14:58:43 +0000
commitd7f711110c474613adef6002e91a34d1bfa309ea (patch)
tree2ff6aec7802c3c7e3dca5f589767c0870b36fee6 /xfce-extra/xfce4-kbdleds-plugin/xfce4-kbdleds-plugin-0.0.6.ebuild
parentAnother revbump to really fix the provider string, bug #388113 thanks to Ralp... (diff)
downloadhistorical-d7f711110c474613adef6002e91a34d1bfa309ea.tar.gz
historical-d7f711110c474613adef6002e91a34d1bfa309ea.tar.bz2
historical-d7f711110c474613adef6002e91a34d1bfa309ea.zip
Initial commit.
Package-Manager: portage-2.2.0_alpha70/cvs/Linux x86_64
Diffstat (limited to 'xfce-extra/xfce4-kbdleds-plugin/xfce4-kbdleds-plugin-0.0.6.ebuild')
-rw-r--r--xfce-extra/xfce4-kbdleds-plugin/xfce4-kbdleds-plugin-0.0.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-kbdleds-plugin/xfce4-kbdleds-plugin-0.0.6.ebuild b/xfce-extra/xfce4-kbdleds-plugin/xfce4-kbdleds-plugin-0.0.6.ebuild
new file mode 100644
index 000000000000..f5833295f3ee
--- /dev/null
+++ b/xfce-extra/xfce4-kbdleds-plugin/xfce4-kbdleds-plugin-0.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-kbdleds-plugin/xfce4-kbdleds-plugin-0.0.6.ebuild,v 1.1 2011/10/22 14:58:43 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="A panel plug-in to show state of Caps, Num and Scroll Lock keys"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-kbdleds-plugin"
+SRC_URI="http://compas.com.ua/oco/file/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/libxfce4ui-4.8
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/xfce4-panel-4.8
+ >=x11-libs/gtk+-2.20:2"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=( $(xfconf_use_debug) )
+ DOCS=( AUTHORS README THANKS ) # ChangeLog NEWS TODO
+}