summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-11-12 10:39:59 +0000
committerJustin Lecher <jlec@gentoo.org>2011-11-12 10:39:59 +0000
commit7169606138f55f4cd3014c16396e8f97c2e4754e (patch)
tree6ab9a568edfb96eee6c9b6763ede93f7b2280591 /x11-wm
parentVersion bump. Bug #390135 (diff)
downloadhistorical-7169606138f55f4cd3014c16396e8f97c2e4754e.tar.gz
historical-7169606138f55f4cd3014c16396e8f97c2e4754e.tar.bz2
historical-7169606138f55f4cd3014c16396e8f97c2e4754e.zip
Corrected slotting for png and tiff
Package-Manager: portage-2.2.0_alpha73/cvs/Linux x86_64
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/afterstep/ChangeLog5
-rw-r--r--x11-wm/afterstep/afterstep-2.2.9.ebuild28
2 files changed, 19 insertions, 14 deletions
diff --git a/x11-wm/afterstep/ChangeLog b/x11-wm/afterstep/ChangeLog
index ffe3c0c4a4b5..90bf883638c5 100644
--- a/x11-wm/afterstep/ChangeLog
+++ b/x11-wm/afterstep/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-wm/afterstep
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.98 2011/10/06 12:19:45 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.99 2011/11/12 10:39:59 jlec Exp $
+
+ 12 Nov 2011; Justin Lecher <jlec@gentoo.org> afterstep-2.2.9.ebuild:
+ Corrected slotting for png and tiff
06 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> afterstep-2.2.9.ebuild,
+files/afterstep-2.2.9-libpng15.patch:
diff --git a/x11-wm/afterstep/afterstep-2.2.9.ebuild b/x11-wm/afterstep/afterstep-2.2.9.ebuild
index b7b7cd45bafc..cfb8855c4b74 100644
--- a/x11-wm/afterstep/afterstep-2.2.9.ebuild
+++ b/x11-wm/afterstep/afterstep-2.2.9.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.9.ebuild,v 1.17 2011/10/06 12:19:45 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.9.ebuild,v 1.18 2011/11/12 10:39:59 jlec Exp $
EAPI=4
+
inherit autotools flag-o-matic eutils
-DESCRIPTION="AfterStep is a feature rich NeXTish window manager"
-HOMEPAGE="http://www.afterstep.org"
+DESCRIPTION="A feature rich NeXTish window manager"
+HOMEPAGE="http://www.afterstep.org/"
SRC_URI="ftp://ftp.afterstep.org/stable/AfterStep-${PV}.tar.bz2"
# libAfterBase/libAfterImage are LGPL
@@ -15,15 +16,16 @@ SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
IUSE="alsa debug dbus gif gtk jpeg mmx nls png svg tiff xinerama"
-RDEPEND="media-libs/freetype
+RDEPEND="
+ media-libs/freetype
alsa? ( media-libs/alsa-lib )
dbus? ( sys-apps/dbus )
jpeg? ( virtual/jpeg )
gif? ( >=media-libs/giflib-4.1.0 )
gtk? ( x11-libs/gtk+:2 )
- png? ( >=media-libs/libpng-1.2.5 )
+ png? ( media-libs/libpng:0 )
svg? ( gnome-base/librsvg:2 )
- tiff? ( >=media-libs/tiff-3.5.7 )
+ tiff? ( media-libs/tiff:0 )
x11-libs/libICE
x11-libs/libXext
x11-libs/libSM
@@ -68,12 +70,6 @@ src_prepare() {
cp "${S}"/autoconf/configure "${S}" || die
}
-src_compile() {
- # gcc: ../libAfterConf/libAfterConf.a: No such file or directory
- # make[1]: *** [PrintDesktopEntries] Error 1
- emake -j1
-}
-
src_configure() {
local myconf
@@ -110,8 +106,14 @@ src_configure() {
${myconf}
}
+src_compile() {
+ # gcc: ../libAfterConf/libAfterConf.a: No such file or directory
+ # make[1]: *** [PrintDesktopEntries] Error 1
+ emake -j1
+}
+
src_install() {
- emake DESTDIR="${D}" install
+ default
# Create a symlink from MonitorWharf to Wharf
rm "${D}"/usr/bin/MonitorWharf