summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-25 03:59:21 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-25 03:59:21 +0000
commit65e748dbdcd935d4e2fb8d68965eb21da8f2b011 (patch)
treeb288d1346851a83fd40e8f86b5b255659117c030 /x11-themes
parentfix major problem with SRC_URI (diff)
downloadhistorical-65e748dbdcd935d4e2fb8d68965eb21da8f2b011.tar.gz
historical-65e748dbdcd935d4e2fb8d68965eb21da8f2b011.tar.bz2
historical-65e748dbdcd935d4e2fb8d68965eb21da8f2b011.zip
fixes compile bugs with gcc-2.95. #16063
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/redhat-artwork/ChangeLog10
-rw-r--r--x11-themes/redhat-artwork/files/redhat-artwork-0.63-cursors.patch31
-rw-r--r--x11-themes/redhat-artwork/redhat-artwork-0.63-r1.ebuild7
-rw-r--r--x11-themes/redhat-artwork/redhat-artwork-0.65.ebuild8
4 files changed, 53 insertions, 3 deletions
diff --git a/x11-themes/redhat-artwork/ChangeLog b/x11-themes/redhat-artwork/ChangeLog
index 7d15d73df5b3..afc3403ef4f2 100644
--- a/x11-themes/redhat-artwork/ChangeLog
+++ b/x11-themes/redhat-artwork/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-themes/redhat-artwork
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/ChangeLog,v 1.15 2003/02/22 18:38:10 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/ChangeLog,v 1.16 2003/03/25 03:59:21 liquidx Exp $
+
+*redhat-artwork-0.63-r1 (25 Mar 2003)
+
+ 25 Mar 2003; Alastair Tse <liquidx@gentoo.org>
+ redhat-artwork-0.63-r1.ebuild, redhat-artwork-0.65.ebuild,
+ files/redhat-artwork-0.63-cursors.patch:
+ patched broken cursortheme sources. thanks to TGL <degrenier@easyconnect.fr>.
+ fixes #16063.
*redhat-artwork-0.65 (21 Feb 2003)
diff --git a/x11-themes/redhat-artwork/files/redhat-artwork-0.63-cursors.patch b/x11-themes/redhat-artwork/files/redhat-artwork-0.63-cursors.patch
new file mode 100644
index 000000000000..8680d694feae
--- /dev/null
+++ b/x11-themes/redhat-artwork/files/redhat-artwork-0.63-cursors.patch
@@ -0,0 +1,31 @@
+*** art/cursor/cursorthemegen/main.c.orig Thu Feb 27 19:37:28 2003
+--- art/cursor/cursorthemegen/main.c Thu Feb 27 19:38:53 2003
+***************
+*** 236,247 ****
+ {
+ CursorImage *image = cursor_source_find_image (source, frame_index);
+ int x, y, width, height;
+!
+ cursor_frame_find_bounds (cursor, frame, source, frame_index,
+ &x, &y, &width, &height);
+
+! GdkPixbuf *tmp_pixbuf = gdk_pixbuf_new_subpixbuf (image->image,
+! x, y, width, height);
+
+ frame->hot_x -= x - cursor->column * source->gridsize;
+ frame->hot_y -= y - cursor->row * source->gridsize;
+--- 236,249 ----
+ {
+ CursorImage *image = cursor_source_find_image (source, frame_index);
+ int x, y, width, height;
+!
+! GdkPixbuf *tmp_pixbuf;
+!
+ cursor_frame_find_bounds (cursor, frame, source, frame_index,
+ &x, &y, &width, &height);
+
+! tmp_pixbuf = gdk_pixbuf_new_subpixbuf (image->image,
+! x, y, width, height);
+
+ frame->hot_x -= x - cursor->column * source->gridsize;
+ frame->hot_y -= y - cursor->row * source->gridsize;
diff --git a/x11-themes/redhat-artwork/redhat-artwork-0.63-r1.ebuild b/x11-themes/redhat-artwork/redhat-artwork-0.63-r1.ebuild
index c85ca7cf5c90..216b22d5327a 100644
--- a/x11-themes/redhat-artwork/redhat-artwork-0.63-r1.ebuild
+++ b/x11-themes/redhat-artwork/redhat-artwork-0.63-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.63-r1.ebuild,v 1.1 2003/02/18 13:41:08 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.63-r1.ebuild,v 1.2 2003/03/25 03:59:21 liquidx Exp $
+
+inherit eutils
RH_EXTRAVERSION="1"
@@ -46,11 +48,14 @@ src_unpack() {
rpm2targz ${DISTDIR}/${A}
tar xzf ${P}*.src.tar.gz
tar xzf ${P}.tar.gz
+ cd ${S}; epatch ${FILESDIR}/redhat-artwork-0.63-cursors.patch || die
}
src_compile() {
export WANT_AUTOCONF_2_5=1
+ # build fails with UTF-8 in locale
+ export LANG=C
# disable qt and kde support if kde use keyword is not set
# note: qt and kde support seem to be tied together... maybe someone with
diff --git a/x11-themes/redhat-artwork/redhat-artwork-0.65.ebuild b/x11-themes/redhat-artwork/redhat-artwork-0.65.ebuild
index d416c2062ef5..bd5fdf0809d0 100644
--- a/x11-themes/redhat-artwork/redhat-artwork-0.65.ebuild
+++ b/x11-themes/redhat-artwork/redhat-artwork-0.65.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.65.ebuild,v 1.4 2003/02/22 18:38:10 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.65.ebuild,v 1.5 2003/03/25 03:59:21 liquidx Exp $
+
+inherit eutils
RH_EXTRAVERSION="1"
@@ -46,11 +48,15 @@ src_unpack() {
rpm2targz ${DISTDIR}/${A}
tar xzf ${P}*.src.tar.gz
tar xzf ${P}.tar.gz
+ cd ${S}
+ epatch ${FILESDIR}/redhat-artwork-0.63-cursors.patch || die
}
src_compile() {
export WANT_AUTOCONF_2_5=1
+ # dies is LANG has UTF-8
+ export LANG=C
use kde || (