summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-02-26 14:12:07 +0000
committerAlex Alexander <wired@gentoo.org>2010-02-26 14:12:07 +0000
commit2b5c1e1a7e4921524877e94b25307491fef3fe1f (patch)
treec144438048d378ccec6619de2b8ea07a6c81f0dd /x11-themes
parent[x11-themes/gtk-engines-qtcurve] version bump (diff)
downloadhistorical-2b5c1e1a7e4921524877e94b25307491fef3fe1f.tar.gz
historical-2b5c1e1a7e4921524877e94b25307491fef3fe1f.tar.bz2
historical-2b5c1e1a7e4921524877e94b25307491fef3fe1f.zip
[x11-themes/qtcurve-qt4] version bump
Package-Manager: portage-2.2_rc63/cvs/Linux x86_64
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/qtcurve-qt4/ChangeLog8
-rw-r--r--x11-themes/qtcurve-qt4/files/qtcurve-qt4-1.1.1-no-kde-fail.patch24
-rw-r--r--x11-themes/qtcurve-qt4/qtcurve-qt4-1.1.1.ebuild43
3 files changed, 74 insertions, 1 deletions
diff --git a/x11-themes/qtcurve-qt4/ChangeLog b/x11-themes/qtcurve-qt4/ChangeLog
index 88cfebf3aaea..a55c8ad5447d 100644
--- a/x11-themes/qtcurve-qt4/ChangeLog
+++ b/x11-themes/qtcurve-qt4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/qtcurve-qt4
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.95 2010/02/23 08:08:08 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.96 2010/02/26 14:12:06 wired Exp $
+
+*qtcurve-qt4-1.1.1 (26 Feb 2010)
+
+ 26 Feb 2010; Alex Alexander <wired@gentoo.org> +qtcurve-qt4-1.1.1.ebuild,
+ +files/qtcurve-qt4-1.1.1-no-kde-fail.patch:
+ version bump, patch to fix -kde compilation
*qtcurve-qt4-1.1.0 (23 Feb 2010)
diff --git a/x11-themes/qtcurve-qt4/files/qtcurve-qt4-1.1.1-no-kde-fail.patch b/x11-themes/qtcurve-qt4/files/qtcurve-qt4-1.1.1-no-kde-fail.patch
new file mode 100644
index 000000000000..92651019f7f0
--- /dev/null
+++ b/x11-themes/qtcurve-qt4/files/qtcurve-qt4-1.1.1-no-kde-fail.patch
@@ -0,0 +1,24 @@
+--- style/qtcurve.cpp.old 2010-02-26 16:06:50.280829619 +0200
++++ style/qtcurve.cpp 2010-02-26 16:07:31.224827593 +0200
+@@ -7451,9 +7451,8 @@
+
+ opt.state=State_Horizontal|State_Enabled|State_Raised|(active ? State_Active : State_None);
+
+-#ifdef QTC_QT_ONLY
+- QPainterPath path;
+-#elif KDE_IS_VERSION(4, 3, 0)
++#ifndef QTC_QT_ONLY
++ #if KDE_IS_VERSION(4, 3, 0)
+ QPainterPath path(opts.round<ROUND_SLIGHT
+ ? QPainterPath()
+ : buildPath(QRectF(state&QtC_StateKWinNoBorder ? r : r.adjusted(1, 1, -1, 0)),
+@@ -7462,6 +7461,9 @@
+ (opts.round>ROUND_SLIGHT /*&& kwin*/
+ ? 6.0
+ : 2.0)-(state&QtC_StateKWinNoBorder ? 0.0 : 1.0)));
++ #else
++ QPainterPath path;
++ #endif
+ #else
+ QPainterPath path;
+ #endif
diff --git a/x11-themes/qtcurve-qt4/qtcurve-qt4-1.1.1.ebuild b/x11-themes/qtcurve-qt4/qtcurve-qt4-1.1.1.ebuild
new file mode 100644
index 000000000000..36bafad584e7
--- /dev/null
+++ b/x11-themes/qtcurve-qt4/qtcurve-qt4-1.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/qtcurve-qt4-1.1.1.ebuild,v 1.1 2010/02/26 14:12:06 wired Exp $
+
+EAPI="2"
+KDE_REQUIRED="optional"
+KDE_MINIMAL="4.2"
+inherit confutils cmake-utils kde4-base
+
+MY_P="${P/qtcurve-qt4/QtCurve-KDE4}"
+DESCRIPTION="A set of widget styles for Qt4 based apps, also available for GTK2"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://craigd.wikispaces.com/file/view/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kde windeco"
+
+DEPEND="x11-libs/qt-gui:4[dbus]
+ x11-libs/qt-svg:4
+ kde? ( >=kde-base/systemsettings-${KDE_MINIMAL}
+ windeco? ( >=kde-base/kwin-${KDE_MINIMAL} ) )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+DOCS="ChangeLog README TODO"
+
+PATCHES=( "${FILESDIR}/${P}-no-kde-fail.patch" )
+
+pkg_setup() {
+ confutils_use_depend_all windeco kde
+ use kde && kde4-base_pkg_setup
+}
+
+src_configure() {
+ if use kde; then
+ kde4-base_src_configure
+ else
+ mycmakeargs="-DQTC_QT_ONLY=true"
+ cmake-utils_src_configure
+ fi
+}