summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-09-11 08:44:55 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-09-11 08:44:55 +0000
commit75df24dcd736ddc707869723c528ec816530c55c (patch)
treedec37ce34a9a6dd193eebe028e0f072f6eba0a5c /x11-plugins/pidgin-facebookchat
parentenewuser/enewgroup die on their own, no need to || die. Fixed quotation. (diff)
downloadhistorical-75df24dcd736ddc707869723c528ec816530c55c.tar.gz
historical-75df24dcd736ddc707869723c528ec816530c55c.tar.bz2
historical-75df24dcd736ddc707869723c528ec816530c55c.zip
Initial import. Closes bug #234625
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26-gentoo x86_64
Diffstat (limited to 'x11-plugins/pidgin-facebookchat')
-rw-r--r--x11-plugins/pidgin-facebookchat/ChangeLog10
-rw-r--r--x11-plugins/pidgin-facebookchat/Manifest4
-rw-r--r--x11-plugins/pidgin-facebookchat/metadata.xml10
-rw-r--r--x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.35.ebuild37
4 files changed, 61 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-facebookchat/ChangeLog b/x11-plugins/pidgin-facebookchat/ChangeLog
new file mode 100644
index 000000000000..cff5e8c83341
--- /dev/null
+++ b/x11-plugins/pidgin-facebookchat/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-plugins/pidgin-facebookchat
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-facebookchat/ChangeLog,v 1.1 2008/09/11 08:44:55 voyageur Exp $
+
+*pidgin-facebookchat-1.35 (11 Sep 2008)
+
+ 11 Sep 2008; Bernard Cafarelli <voyageur@gentoo.org> +metadata.xml,
+ +pidgin-facebookchat-1.35.ebuild:
+ Initial import. Closes bug #234625
+
diff --git a/x11-plugins/pidgin-facebookchat/Manifest b/x11-plugins/pidgin-facebookchat/Manifest
new file mode 100644
index 000000000000..fc3cb9ac572a
--- /dev/null
+++ b/x11-plugins/pidgin-facebookchat/Manifest
@@ -0,0 +1,4 @@
+DIST pidgin-facebookchat-source-1.35.tar.bz2 33697 RMD160 4eee9b5312436cbe9355201a97ee04d3cfcb9d0a SHA1 4cfe2c464158b6418889d22e2035a0f8ad15b527 SHA256 2ded6c5777b47c26dc79203cf25db0e58aa3d43f95cad159ce80feb8e1df954f
+EBUILD pidgin-facebookchat-1.35.ebuild 1030 RMD160 7215845d1afd9511cfe95f8303f9322bf6434da3 SHA1 98a42bf6b00b92c4a01cf357d0f97b208d43d6f3 SHA256 0d008020d5754cf7d685632d14b8e14c9603b2b81b59197c01c7805054ad2eaa
+MISC ChangeLog 422 RMD160 3281b2fa8425743272b717ce8ab7632f04ef255a SHA1 64729e8d90005b7b0dfc92c5fdaafcd769d5baf4 SHA256 237305ac442698393a64899555443fdcbba6358b8af00b40ced1ea4d68608bdd
+MISC metadata.xml 433 RMD160 074a4478b9de2144f8e1e09d56df5a61421aaae6 SHA1 a5971c1f6365ed5612612db3d5d79753d096cddb SHA256 27383995b7c16a20ec0f468e1a36921adb752da56981dc67181411da151a9e31
diff --git a/x11-plugins/pidgin-facebookchat/metadata.xml b/x11-plugins/pidgin-facebookchat/metadata.xml
new file mode 100644
index 000000000000..0ad75e70ae8c
--- /dev/null
+++ b/x11-plugins/pidgin-facebookchat/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-im</herd>
+ <maintainer>
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <longdescription>Facebook chat plugin for Pidgin and libpurple messengers. It connects to the new Facebook Chat IM service without the need for an API key</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.35.ebuild b/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.35.ebuild
new file mode 100644
index 000000000000..4c175050906c
--- /dev/null
+++ b/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.35.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.35.ebuild,v 1.1 2008/09/11 08:44:55 voyageur Exp $
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Facebook chat plugin for libpurple"
+HOMEPAGE="http://code.google.com/p/pidgin-facebookchat/"
+
+SRC_URI="http://pidgin-facebookchat.googlecode.com/files/${PN}-source-${PV}.tar.bz2"
+LICENSE="GPL-3"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+S=${WORKDIR}
+
+src_compile() {
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} `pkg-config --cflags purple` \
+ -DPURPLE_PLUGINS -DENABLE_NLS -shared -fPIC -DPIC \
+ libfacebook.c -o libfacebook.so || die "compilation failed"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/purple-2
+ doexe libfacebook.so
+ for size in 16 22 48; do
+ insinto /usr/share/pixmaps/pidgin/protocols/${size}
+ newins facebook${size}.png facebook.png
+ done
+}