summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2004-03-06 10:12:08 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2004-03-06 10:12:08 +0000
commitb0434c23b1aff447dd3686152e32fbeb6f5a8c7f (patch)
tree890028f8b205c1d1313bd5db087b77a1d9d040d8 /x11-misc/xrootconsole
parentAdded to ~ppc (diff)
downloadhistorical-b0434c23b1aff447dd3686152e32fbeb6f5a8c7f.tar.gz
historical-b0434c23b1aff447dd3686152e32fbeb6f5a8c7f.tar.bz2
historical-b0434c23b1aff447dd3686152e32fbeb6f5a8c7f.zip
Added patch to enable RGB color parsing. Thanks to Martin Parm <parmus@diku.dk> (bug #41969).
Diffstat (limited to 'x11-misc/xrootconsole')
-rw-r--r--x11-misc/xrootconsole/ChangeLog11
-rw-r--r--x11-misc/xrootconsole/files/digest-xrootconsole-0.4-r11
-rw-r--r--x11-misc/xrootconsole/files/xrootconsole-0.4.parse-color.patch23
-rw-r--r--x11-misc/xrootconsole/xrootconsole-0.4-r1.ebuild23
4 files changed, 56 insertions, 2 deletions
diff --git a/x11-misc/xrootconsole/ChangeLog b/x11-misc/xrootconsole/ChangeLog
index 282dfbfd5ff8..d3bbac899f89 100644
--- a/x11-misc/xrootconsole/ChangeLog
+++ b/x11-misc/xrootconsole/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/xrootconsole
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrootconsole/ChangeLog,v 1.6 2003/11/04 03:40:44 abhishek Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrootconsole/ChangeLog,v 1.7 2004/03/06 10:12:08 pyrania Exp $
+
+*xrootconsole-0.4-r1 (06 Mar 2004)
+
+ 06 Mar 2004; Markus Nigbur <pyrania@gentoo.org> xrootconsole-0.4-r1.ebuild,
+ files/xrootconsole-0.4.parse-color.patch:
+ Added patch to enable RGB color parsing. Thanks to Martin Parm
+ <parmus@diku.dk> (bug #41969).
03 Nov 2003; Abhishek Amit <abhishek@gentoo.org> metadata.xml:
Added metadata.xml
diff --git a/x11-misc/xrootconsole/files/digest-xrootconsole-0.4-r1 b/x11-misc/xrootconsole/files/digest-xrootconsole-0.4-r1
new file mode 100644
index 000000000000..461eaa33aea4
--- /dev/null
+++ b/x11-misc/xrootconsole/files/digest-xrootconsole-0.4-r1
@@ -0,0 +1 @@
+MD5 528feb9dd856712fd022ba0a5b586129 xrootconsole-0.4.tar.gz 15397
diff --git a/x11-misc/xrootconsole/files/xrootconsole-0.4.parse-color.patch b/x11-misc/xrootconsole/files/xrootconsole-0.4.parse-color.patch
new file mode 100644
index 000000000000..78114de4df5b
--- /dev/null
+++ b/x11-misc/xrootconsole/files/xrootconsole-0.4.parse-color.patch
@@ -0,0 +1,23 @@
+diff -u xrootconsole-0.4/util.c xrootconsole-0.4.new/util.c
+--- xrootconsole-0.4/util.c 2000-10-10 04:17:53.000000000 +0200
++++ xrootconsole-0.4.new/util.c 2004-02-17 23:59:45.000000000 +0100
+@@ -53,16 +53,16 @@
+
+
+ unsigned long load_color(const char* s, Display *dpy) {
+- XColor ce, cs;
++ XColor ce;
+ Colormap colormap = DefaultColormap(dpy, DefaultScreen(dpy));
+
+- if (XLookupColor(dpy, colormap, s, &ce, &cs)) {
++ if (XParseColor(dpy, colormap, s, &ce)) {
+ if (XAllocColor(dpy, colormap, &ce)) return ce.pixel;
+
+ fprintf(stderr, "Warning: could not allocate color\n");
+ return WhitePixel(dpy, DefaultScreen(dpy));
+ }
+
+- fprintf(stderr, "Warning: could not lookup color\n");
++ fprintf(stderr, "Warning: could not parse color\n");
+ return WhitePixel(dpy, DefaultScreen(dpy));
+ }
diff --git a/x11-misc/xrootconsole/xrootconsole-0.4-r1.ebuild b/x11-misc/xrootconsole/xrootconsole-0.4-r1.ebuild
new file mode 100644
index 000000000000..91323eaee5eb
--- /dev/null
+++ b/x11-misc/xrootconsole/xrootconsole-0.4-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrootconsole/xrootconsole-0.4-r1.ebuild,v 1.1 2004/03/06 10:12:08 pyrania Exp $
+
+DESCRIPTION="An utillity that displays its input in a text box on your root window"
+HOMEPAGE="http://de-fac.to/bob/xrootconsole/"
+SRC_URI="http://de-fac.to/bob/xrootconsole/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc "
+
+DEPEND="x11-base/xfree"
+
+src_compile() {
+ epatch ${FILESDIR}/${P}.parse-color.patch
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ make BINDIR=${D}usr/bin/ install || die "install failed"
+}