summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2005-03-18 06:07:54 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2005-03-18 06:07:54 +0000
commitc40723d6b76d0cb38f288fd441f59a7cd7845b42 (patch)
tree90d413786f05cb5700c99134996e378bbff52eb9 /x11-misc/wmakerconf
parentstyle syncage (diff)
downloadhistorical-c40723d6b76d0cb38f288fd441f59a7cd7845b42.tar.gz
historical-c40723d6b76d0cb38f288fd441f59a7cd7845b42.tar.bz2
historical-c40723d6b76d0cb38f288fd441f59a7cd7845b42.zip
wmakerconf finally updated to support windowmaker-0.9X series
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'x11-misc/wmakerconf')
-rw-r--r--x11-misc/wmakerconf/ChangeLog8
-rw-r--r--x11-misc/wmakerconf/Manifest4
-rw-r--r--x11-misc/wmakerconf/files/digest-wmakerconf-2.111
-rw-r--r--x11-misc/wmakerconf/wmakerconf-2.11.ebuild50
4 files changed, 61 insertions, 2 deletions
diff --git a/x11-misc/wmakerconf/ChangeLog b/x11-misc/wmakerconf/ChangeLog
index 0b511750ef7d..3455022d5f67 100644
--- a/x11-misc/wmakerconf/ChangeLog
+++ b/x11-misc/wmakerconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/wmakerconf
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/ChangeLog,v 1.16 2005/02/26 12:39:14 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/ChangeLog,v 1.17 2005/03/18 06:07:53 fafhrd Exp $
+
+*wmakerconf-2.11 (18 Mar 2005)
+
+ 18 Mar 2005; Armando Di Cianno <fafhrd@gentoo.org>
+ +wmakerconf-2.11.ebuild:
+ wmakerconf finally updated to support windowmaker-0.9X series
26 Feb 2005; Simon Stelling <blubb@gentoo.org> wmakerconf-2.9.2.ebuild:
added ~amd64
diff --git a/x11-misc/wmakerconf/Manifest b/x11-misc/wmakerconf/Manifest
index df0e8facf3b0..3cc81fff8c0c 100644
--- a/x11-misc/wmakerconf/Manifest
+++ b/x11-misc/wmakerconf/Manifest
@@ -1,8 +1,10 @@
-MD5 d464487fd4e792d9f765167cc7fafb37 ChangeLog 1950
+MD5 60b8229f97ab1ce5a546911325ee37af ChangeLog 2128
MD5 e3da37041f1ea1df94a3fe8b6df1f7fb metadata.xml 327
MD5 4a739eeb9d5b7428719e0b92edf8e67c wmakerconf-2.8.1-r2.ebuild 1253
MD5 671f4cc44b90398e8e67e90cc9cd9fb6 wmakerconf-2.9.2.ebuild 1291
MD5 abe35df8dbb13229ba447a5fc8cf7de9 wmakerconf-2.9.ebuild 1234
+MD5 ae0d6396090f85e7b5df1ae625561a05 wmakerconf-2.11.ebuild 1185
MD5 1e9fc0f7bee345603a1202c29ea3f14e files/digest-wmakerconf-2.8.1-r2 68
MD5 171d06c45d91a642a89bebb5e60f2cd5 files/digest-wmakerconf-2.9 67
MD5 9836fda7307d1de81541a6ce1f894070 files/digest-wmakerconf-2.9.2 68
+MD5 08460ad64726481d73b93e68c86d20f3 files/digest-wmakerconf-2.11 67
diff --git a/x11-misc/wmakerconf/files/digest-wmakerconf-2.11 b/x11-misc/wmakerconf/files/digest-wmakerconf-2.11
new file mode 100644
index 000000000000..d8ea1df9d440
--- /dev/null
+++ b/x11-misc/wmakerconf/files/digest-wmakerconf-2.11
@@ -0,0 +1 @@
+MD5 d98ff7f6c18cd0d6ffdfa0a990bcf698 wmakerconf-2.11.tar.gz 791166
diff --git a/x11-misc/wmakerconf/wmakerconf-2.11.ebuild b/x11-misc/wmakerconf/wmakerconf-2.11.ebuild
new file mode 100644
index 000000000000..e4638fef86ea
--- /dev/null
+++ b/x11-misc/wmakerconf/wmakerconf-2.11.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/wmakerconf-2.11.ebuild,v 1.1 2005/03/18 06:07:54 fafhrd Exp $
+
+inherit eutils
+
+DESCRIPTION="X based config tool for the windowmaker X windowmanager."
+SRC_URI="http://www.starplot.org/wmakerconf/${P}.tar.gz"
+HOMEPAGE="http://www.starplot.org/wmakerconf/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~x86"
+
+IUSE="nls imlib perl"
+
+DEPEND="=x11-libs/gtk+-2*
+ >=x11-wm/windowmaker-0.90.0
+ imlib? ( media-libs/imlib )"
+
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )
+ perl? ( dev-lang/perl
+ dev-perl/HTML-Parser
+ dev-perl/libwww-perl
+ www-client/lynx
+ net-misc/wget )"
+
+src_compile() {
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+ use imlib || myconf="${myconf} --disable-imlibtest"
+ if use perl; then
+ myconf="${myconf} --enable-upgrade"
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} \
+ gnulocaledir=${D}/usr/share/locale \
+ install || die "install failed"
+
+ dodoc README NEWS INSTALL MANUAL AUTHORS TODO COPYING ChangeLog
+ doman man/*
+}
+