summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Hale <tseng@gentoo.org>2003-12-07 00:17:16 +0000
committerBrandon Hale <tseng@gentoo.org>2003-12-07 00:17:16 +0000
commitef1c65311fa78a5a99bc33285a9dbf9513e53d0f (patch)
treefefe5e6bcb768256e543e169e1008e122c06d69a /x11-misc/root-portal
parentVersion bump. (diff)
downloadhistorical-ef1c65311fa78a5a99bc33285a9dbf9513e53d0f.tar.gz
historical-ef1c65311fa78a5a99bc33285a9dbf9513e53d0f.tar.bz2
historical-ef1c65311fa78a5a99bc33285a9dbf9513e53d0f.zip
Version bump.
Diffstat (limited to 'x11-misc/root-portal')
-rw-r--r--x11-misc/root-portal/Manifest4
-rw-r--r--x11-misc/root-portal/files/digest-root-portal-0.5.01
-rw-r--r--x11-misc/root-portal/root-portal-0.5.0.ebuild62
3 files changed, 65 insertions, 2 deletions
diff --git a/x11-misc/root-portal/Manifest b/x11-misc/root-portal/Manifest
index b113d3644209..b2aa5c25bf9c 100644
--- a/x11-misc/root-portal/Manifest
+++ b/x11-misc/root-portal/Manifest
@@ -1,7 +1,7 @@
-MD5 71a4fdb7c702cdbb9ba6632504101381 ChangeLog 674
+MD5 45d457b4cfdcf697e2a42d1b3389e8d3 ChangeLog 797
MD5 cdb11033a3fa6525334cecf938961c07 metadata.xml 166
MD5 ecb271a328f98122f269e3f1fb2d3e2d root-portal-0.4.11.ebuild 1852
-MD5 ba63cc9e94cfff6e6fec251bccd78f57 root-portal-0.5.0.ebuild 1853
+MD5 ca611bec32aa28d0fcb7d04866cdc35a root-portal-0.5.0.ebuild 1814
MD5 8a6d14539df2b912f17d1f78a54a1e4b files/0.4.11-gcc3.patch 2455
MD5 c2474198f20ec00a050dd0b6adcac40e files/digest-root-portal-0.4.11 70
MD5 f9d2acb2ede1a736f915ef1ed10020e2 files/digest-root-portal-0.5.0 69
diff --git a/x11-misc/root-portal/files/digest-root-portal-0.5.0 b/x11-misc/root-portal/files/digest-root-portal-0.5.0
new file mode 100644
index 000000000000..63d60a321a47
--- /dev/null
+++ b/x11-misc/root-portal/files/digest-root-portal-0.5.0
@@ -0,0 +1 @@
+MD5 9b3eff0eed13bc659b485d5c5661a03f root-portal-0.5.0.tar.gz 426038
diff --git a/x11-misc/root-portal/root-portal-0.5.0.ebuild b/x11-misc/root-portal/root-portal-0.5.0.ebuild
new file mode 100644
index 000000000000..2f1db2812630
--- /dev/null
+++ b/x11-misc/root-portal/root-portal-0.5.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/root-portal/root-portal-0.5.0.ebuild,v 1.1 2003/12/07 00:16:59 tseng Exp $
+
+inherit debug
+
+DESCRIPTION="A program to draw text and graphs in the root window"
+HOMEPAGE="http://root-portal.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="gnome"
+
+# Build-time dependencies, such as
+# ssl? ( >=openssl-0.9.6b )
+# >=perl-5.6.1-r1
+DEPEND="virtual/x11
+ =x11-libs/gtk+-1.2*
+ >=gnome-base/ORBit-0.5.7
+ >=gnome-base/gnome-libs-1.4.0
+ <gnome-base/gnome-panel-2
+ >=dev-libs/libxml-1.8.16 "
+# the tabulated section is only needed if Gnome is in USE, but their disable-gnome doesn't work for now.
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ local myconf="--enable-debug --enable-test --enable-crash-debug"
+ ## Theres an upstream bug (filed) that disables this. when the next version is out, uncomment theese lines and it should work
+
+
+# use gnome && myconf="${myconf} --enable-gnometext-builtin --enable-shell-builtin"
+# use gnome || myconf="${myconf} --without-gnome --without-gnome-libs --disable-gnometext-builtin --disable-shell-builtin"
+
+ econf \
+ --enable-gnometext \
+ --enable-shell \
+ --enable-console \
+ --enable-fifo \
+ --enable-filetail \
+ --enable-graph \
+ --enable-process-builtin \
+ --enable-modifier \
+ --enable-networkload \
+ --enable-remote \
+ --enable-roottext \
+ --enable-systemload \
+ --enable-consoledump \
+ ${myconf} \
+ || die "configure failure. please file a bugreport"
+ emake || die "compile failure. please file a bugreport"
+}
+
+src_install() {
+ einstall || die
+ dodoc PACKAGING README NEWS ChangeLog BUGS AUTHORS README.help TODO
+}