summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-05 10:02:51 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-05 10:02:51 +0000
commitca2ca9b65bbc3ab8ee486afb137316bc97db3903 (patch)
tree42d6b7ee1bcc94d68f654ae21c12dcb794558d69 /x11-libs/qt/qt-2.3.2-r1.ebuild
parentperl testing on ppc; added positive test results (diff)
downloadhistorical-ca2ca9b65bbc3ab8ee486afb137316bc97db3903.tar.gz
historical-ca2ca9b65bbc3ab8ee486afb137316bc97db3903.tar.bz2
historical-ca2ca9b65bbc3ab8ee486afb137316bc97db3903.zip
modernised
Diffstat (limited to 'x11-libs/qt/qt-2.3.2-r1.ebuild')
-rw-r--r--x11-libs/qt/qt-2.3.2-r1.ebuild94
1 files changed, 47 insertions, 47 deletions
diff --git a/x11-libs/qt/qt-2.3.2-r1.ebuild b/x11-libs/qt/qt-2.3.2-r1.ebuild
index f15e6f8b4069..e757bc57deaa 100644
--- a/x11-libs/qt/qt-2.3.2-r1.ebuild
+++ b/x11-libs/qt/qt-2.3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-2.3.2-r1.ebuild,v 1.6 2002/07/16 03:16:42 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-2.3.2-r1.ebuild,v 1.7 2002/08/05 10:02:51 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="QT ${PV}, an X11 widget set and general library used by KDE et al"
@@ -28,15 +28,15 @@ export QTDIR=${S}
src_unpack() {
- unpack ${A}
+ unpack ${A}
- cd ${S}
- cp configure configure.orig
- sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
- cd ${S}/configs
- cp linux-g++-shared linux-g++-shared.orig
- sed -e "s/SYSCONF_CXXFLAGS /SYSCONF_CXXFLAGS = ${CXXFLAGS} \#/" \
+ cd ${S}/configs
+ cp linux-g++-shared linux-g++-shared.orig
+ sed -e "s/SYSCONF_CXXFLAGS /SYSCONF_CXXFLAGS = ${CXXFLAGS} \#/" \
-e "s/SYSCONF_CFLAGS /SYSCONF_CFLAGS = ${CFLAGS} \#/" \
linux-g++-shared.orig > linux-g++-shared || die
@@ -44,58 +44,58 @@ src_unpack() {
src_compile() {
- export LDFLAGS="$LDFLAGS -ldl"
- local myconf
+ export LDFLAGS="$LDFLAGS -ldl"
+ local myconf
- use opengl || myconf="$myconf -no-opengl"
- use nas \
- && myconf="${myconf} -system-nas-sound" \
+ use opengl || myconf="$myconf -no-opengl"
+ use nas \
+ && myconf="${myconf} -system-nas-sound" \
|| myconf="${myconf} -no-nas-sound"
- use gif && myconf="${myconf} -gif"
+ use gif && myconf="${myconf} -gif"
- [ -n "$DEBUG" ] \
- && myconf="${myconf} -debug" \
+ [ -n "$DEBUG" ] \
+ && myconf="${myconf} -debug" \
|| myconf="${myconf} -release"
- ./configure \
+ ./configure \
-sm -thread -system-zlib -system-jpeg ${myconf} \
-system-libmng -system-libpng -gif -platform linux-g++ \
- -ldl -lpthread -no-g++-exceptions || die
+ -ldl -lpthread -no-g++-exceptions || die
- cd ${S}
- make symlinks src-moc sub-src sub-tools || die
+ cd ${S}
+ make symlinks src-moc sub-src sub-tools || die
}
src_install() {
- cd ${S}
-
- # binaries
- into $QTBASE
- dobin bin/*
-
- # libraries
- dolib lib/libqt.so.${PV} lib/libqt-mt.so.${PV} lib/libqutil.so.1.0.0
- cd ${D}$QTBASE/lib
- for x in libqt.so libqt-mt.so
- do
- ln -s $x.2.3.1 $x.2.3
- ln -s $x.2.3 $x.2
- ln -s $x.2 $x
- done
- ln -s libqutil.so.1.0.0 libqutil.so.1.0
- ln -s libqutil.so.1.0 libqutil.so.1
- ln -s libqutil.so.1 libqutil.so
-
- # includes
- cd ${S}
- dodir ${QTBASE}/include
- cp include/* ${D}/${QTBASE}/include/
-
- # misc
- insinto /etc/env.d
- doins ${FILESDIR}/{50qt2,45qtdir2}
+ cd ${S}
+
+ # binaries
+ into $QTBASE
+ dobin bin/*
+
+ # libraries
+ dolib lib/libqt.so.${PV} lib/libqt-mt.so.${PV} lib/libqutil.so.1.0.0
+ cd ${D}$QTBASE/lib
+ for x in libqt.so libqt-mt.so
+ do
+ ln -s $x.2.3.1 $x.2.3
+ ln -s $x.2.3 $x.2
+ ln -s $x.2 $x
+ done
+ ln -s libqutil.so.1.0.0 libqutil.so.1.0
+ ln -s libqutil.so.1.0 libqutil.so.1
+ ln -s libqutil.so.1 libqutil.so
+
+ # includes
+ cd ${S}
+ dodir ${QTBASE}/include
+ cp include/* ${D}/${QTBASE}/include/
+
+ # misc
+ insinto /etc/env.d
+ doins ${FILESDIR}/{50qt2,45qtdir2}
}