summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-07-08 17:48:21 +0000
committerTravis Tilley <lv@gentoo.org>2004-07-08 17:48:21 +0000
commitad00ffe61a9506a749ffcff61cf2a56a208d9ec4 (patch)
tree3b612aa3c33fef1ca347467797bf55dd46f92f06 /x11-libs/libast
parentmu-conference-0.6.0-r2 (diff)
downloadhistorical-ad00ffe61a9506a749ffcff61cf2a56a208d9ec4.tar.gz
historical-ad00ffe61a9506a749ffcff61cf2a56a208d9ec4.tar.bz2
historical-ad00ffe61a9506a749ffcff61cf2a56a208d9ec4.zip
added 64bit fix. see bug #52634 for more information
Diffstat (limited to 'x11-libs/libast')
-rw-r--r--x11-libs/libast/ChangeLog6
-rw-r--r--x11-libs/libast/Manifest5
-rw-r--r--x11-libs/libast/files/libast-64bit.patch11
-rw-r--r--x11-libs/libast/libast-0.5-r2.ebuild10
4 files changed, 28 insertions, 4 deletions
diff --git a/x11-libs/libast/ChangeLog b/x11-libs/libast/ChangeLog
index caeaa95a893e..f23f20ac1514 100644
--- a/x11-libs/libast/ChangeLog
+++ b/x11-libs/libast/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/libast
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/ChangeLog,v 1.10 2004/06/24 22:04:09 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/ChangeLog,v 1.11 2004/07/08 17:48:21 lv Exp $
+
+ 08 Jul 2004; Travis Tilley <lv@gentoo.org> +files/libast-64bit.patch,
+ libast-0.5-r2.ebuild:
+ added 64bit fix. see bug #52634 for more information
*libast-0.5-r2 (22 Feb 2004)
diff --git a/x11-libs/libast/Manifest b/x11-libs/libast/Manifest
index d4b93e951bca..ef3411d1a051 100644
--- a/x11-libs/libast/Manifest
+++ b/x11-libs/libast/Manifest
@@ -1,4 +1,5 @@
-MD5 212c05c4dadc5c22e7ef2d196b028a47 libast-0.5-r2.ebuild 832
-MD5 2d2da892350ece999919842270ea383f ChangeLog 1413
+MD5 cdc45c06841b1aa3d69d4f4cac972d8b libast-0.5-r2.ebuild 931
+MD5 537ae744bbe4ca7110a23cceec24c98d ChangeLog 1559
MD5 ec45fec065a8eccc43870fc678126de7 metadata.xml 820
+MD5 bb5de296213b5928dd8f956e40436668 files/libast-64bit.patch 441
MD5 2a9e814b7851e9e22178430153da8110 files/digest-libast-0.5-r2 62
diff --git a/x11-libs/libast/files/libast-64bit.patch b/x11-libs/libast/files/libast-64bit.patch
new file mode 100644
index 000000000000..7aa200279245
--- /dev/null
+++ b/x11-libs/libast/files/libast-64bit.patch
@@ -0,0 +1,11 @@
+diff -Nru libast-0.5.old/include/libast.h libast-0.5/include/libast.h
+--- libast-0.5.old/include/libast.h 2004-07-08 13:39:36.837764880 -0400
++++ libast-0.5/include/libast.h 2004-07-08 13:40:21.287007568 -0400
+@@ -337,6 +337,7 @@
+ /* fill l with c. */ \
+ l = (c) | (c)<<8; \
+ l |= l<<16; \
++ l |= l<<32; \
+ MEMSET_LONG(); \
+ \
+ /* fill in 1-byte chunks until boundary of long is reached. */ \
diff --git a/x11-libs/libast/libast-0.5-r2.ebuild b/x11-libs/libast/libast-0.5-r2.ebuild
index 20ef79071b44..88b4c92364cc 100644
--- a/x11-libs/libast/libast-0.5-r2.ebuild
+++ b/x11-libs/libast/libast-0.5-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.5-r2.ebuild,v 1.3 2004/06/24 22:04:09 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.5-r2.ebuild,v 1.4 2004/07/08 17:48:21 lv Exp $
+
+inherit 64-bit
DESCRIPTION="LIBrary of Assorted Spiffy Things"
HOMEPAGE="http://www.eterm.org/download/"
@@ -16,6 +18,12 @@ DEPEND="virtual/x11
X? ( imlib? ( media-libs/imlib2 ) )
perl? ( dev-libs/libpcre )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ 64-bit && epatch ${FILESDIR}/libast-64bit.patch
+}
+
src_compile() {
local myconf
use X && use imlib \