summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-05-13 12:24:20 +0000
committerPacho Ramos <pacho@gentoo.org>2012-05-13 12:24:20 +0000
commitb65c1516aaa5d9b71257a4df93921b65f1cb7330 (patch)
treed4539d78ae49f69d7e1a72afe2cceddf10cd5d2c /x11-libs/gtkmathview/gtkmathview-0.8.0-r2.ebuild
parentarm stable, bug #415331 (diff)
downloadhistorical-b65c1516aaa5d9b71257a4df93921b65f1cb7330.tar.gz
historical-b65c1516aaa5d9b71257a4df93921b65f1cb7330.tar.bz2
historical-b65c1516aaa5d9b71257a4df93921b65f1cb7330.zip
Drop gmetadom support because it's dead, other distributions are not providing it fore years and I have confirmed none of gtkmathview consumers need this old stuff.
Package-Manager: portage-2.1.10.59/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/gtkmathview/gtkmathview-0.8.0-r2.ebuild')
-rw-r--r--x11-libs/gtkmathview/gtkmathview-0.8.0-r2.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/x11-libs/gtkmathview/gtkmathview-0.8.0-r2.ebuild b/x11-libs/gtkmathview/gtkmathview-0.8.0-r2.ebuild
new file mode 100644
index 000000000000..5b2a711aa443
--- /dev/null
+++ b/x11-libs/gtkmathview/gtkmathview-0.8.0-r2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmathview/gtkmathview-0.8.0-r2.ebuild,v 1.1 2012/05/13 12:24:20 pacho Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="Rendering engine for MathML documents"
+HOMEPAGE="http://helm.cs.unibo.it/mml-widget/"
+SRC_URI="http://helm.cs.unibo.it/mml-widget/sources/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk mathml svg t1lib"
+
+RDEPEND=">=dev-libs/glib-2.2.1:2
+ >=dev-libs/popt-1.7
+ >=dev-libs/libxml2-2.6.7:2
+ gtk? ( >=x11-libs/gtk+-2.2.1:2
+ >=media-libs/t1lib-5:5
+ x11-libs/pango )
+ mathml? ( media-fonts/texcm-ttf )
+ t1lib? ( >=media-libs/t1lib-5:5 )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS="ANNOUNCEMENT AUTHORS BUGS ChangeLog CONTRIBUTORS HISTORY NEWS README TODO"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-cond-t1.patch
+
+ # Fix building against libxml2[icu], bug #356095
+ epatch "${FILESDIR}"/${P}-fix-template.patch
+
+ # Fix building with gold, bug #369117; requires eautoreconf
+ epatch "${FILESDIR}/${P}-underlinking.patch"
+
+ # m4 macros from upstream git, required for eautoreconf
+ if [[ ! -d ac-helpers ]]; then
+ mkdir ac-helpers || die "mkdir failed"
+ cp "${FILESDIR}/binreloc.m4" ac-helpers || die "cp failed"
+ fi
+
+ AT_M4DIR=ac-helpers eautoreconf
+}
+
+src_configure() {
+ # --disable-popt will build only the library and not the frontend
+ # TFM is needed for SVG, default value is 2
+ econf $(use_enable gtk) \
+ $(use_enable svg) \
+ $(use_with t1lib) \
+ --with-popt \
+ --enable-libxml2 \
+ --enable-libxml2-reader \
+ --enable-ps \
+ --enable-tfm=2 \
+ --enable-builder-cache \
+ --enable-breaks \
+ --enable-boxml \
+ --disable-gmetadom \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -exec rm -f {} +
+}