summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-04-29 14:31:00 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-04-29 14:31:00 +0000
commit92dbc8695e52c0eaf906317a91238bd496f19e8f (patch)
tree281592de5826b3211d1ac66d27902712c83b6db5 /www-servers
parentStable on sparc (diff)
downloadhistorical-92dbc8695e52c0eaf906317a91238bd496f19e8f.tar.gz
historical-92dbc8695e52c0eaf906317a91238bd496f19e8f.tar.bz2
historical-92dbc8695e52c0eaf906317a91238bd496f19e8f.zip
added patch to fix #90003. patch also corrects fpic issue for a shared object.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/resin/ChangeLog6
-rw-r--r--www-servers/resin/Manifest11
-rw-r--r--www-servers/resin/files/3.0.12/gentoo.diff25
-rw-r--r--www-servers/resin/resin-3.0.12.ebuild7
4 files changed, 40 insertions, 9 deletions
diff --git a/www-servers/resin/ChangeLog b/www-servers/resin/ChangeLog
index dfd75ae22650..52b2f913400b 100644
--- a/www-servers/resin/ChangeLog
+++ b/www-servers/resin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-servers/resin
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/resin/ChangeLog,v 1.7 2005/04/19 14:03:56 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/resin/ChangeLog,v 1.8 2005/04/29 14:31:00 luckyduck Exp $
+
+ 29 Apr 2005; Jan Brinkmann <luckyduck@gentoo.org> +files/3.0.12/gentoo.diff,
+ resin-3.0.12.ebuild:
+ added patch to fix #90003. patch also corrects fpic issue for a shared object.
19 Apr 2005; Jan Brinkmann <luckyduck@gentoo.org> +files/3.0.12/21resin,
+files/3.0.12/resin.conf, +files/3.0.12/resin.init,
diff --git a/www-servers/resin/Manifest b/www-servers/resin/Manifest
index 7b3054cd7583..d7b2f38e22a3 100644
--- a/www-servers/resin/Manifest
+++ b/www-servers/resin/Manifest
@@ -1,9 +1,9 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 efc36b8d526d3a102496fed289b02eea resin-3.0.12.ebuild 3351
+MD5 7df9e2f5ad8b43f264942e97ff46a3ab resin-3.0.12.ebuild 3436
MD5 ba0f926b1a86775dfaca8cbbcaf5f9f6 resin-3.0.8-r1.ebuild 3370
-MD5 6307234e3b945ce59d45eacef424ce99 ChangeLog 3280
+MD5 3638217ea99b079b7849e1be156329d7 ChangeLog 3464
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 1774ee83435bc1d54cb0905b01dbba12 resin-2.1.14.ebuild 3035
MD5 0e0d2bb7422b3b0f88fe7bb4302738a1 files/digest-resin-2.1.14 65
@@ -20,11 +20,12 @@ MD5 a810be4b68e920ebc5d2cf8160a5642a files/2.1.14/21resin 53
MD5 a06fd833b2ca8f78bf18028b530d52b4 files/3.0.12/resin.conf 1130
MD5 b113cda023ae557981e4b2e36023d401 files/3.0.12/resin.init 549
MD5 5e72e20b51a6013bf62800c1d4c4629e files/3.0.12/21resin 22
+MD5 7d6b40e67e41acafd82feb48350882b6 files/3.0.12/gentoo.diff 1203
MD5 fc791301841bde6c69ec74e35fcc07e9 files/3.0.12/wrapper.pl.diff 526
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFCZQ/n06ebR+OMO78RAsH7AKCBkoABmOfIZWAe/J2UwsZzb6wq5ACglgs2
-V6vAvNVZ0XLcvmr53QskQ0w=
-=k/ii
+iD8DBQFCckU206ebR+OMO78RAtk7AJ0X7xQh/PhXiLLtWt0rW4dpr6nbaQCfds0U
+lpVU+uwQXAaCxvUbrBeh3B0=
+=PU2F
-----END PGP SIGNATURE-----
diff --git a/www-servers/resin/files/3.0.12/gentoo.diff b/www-servers/resin/files/3.0.12/gentoo.diff
new file mode 100644
index 000000000000..1e258a2b0524
--- /dev/null
+++ b/www-servers/resin/files/3.0.12/gentoo.diff
@@ -0,0 +1,25 @@
+--- ../resin-3.0.12/configure 2005-01-12 00:00:26.000000000 +0100
++++ configure 2005-04-29 16:18:15.000000000 +0200
+@@ -8261,6 +8261,10 @@
+ apache_exe="${apache_bin}/httpd"
+ elif test -x "${apache_bin}/httpd2"; then
+ apache_exe="${apache_bin}/httpd2"
++elif test -x "${apache_bin}/apache"; then
++ apache_exe="${apache_bin}/apache"
++elif test -x "${apache_bin}/apache2"; then
++ apache_exe="${apache_bin}/apache2"
+ else
+ { { echo "$as_me:$LINENO: error: Can't find Apache binary in directory ${apache_bin}" >&5
+ echo "$as_me: error: Can't find Apache binary in directory ${apache_bin}" >&2;}
+diff -uprN ../resin-3.0.12/src/c/resin_os/Makefile.in src/c/resin_os/Makefile.in
+--- ../resin-3.0.12/src/c/resin_os/Makefile.in 2004-12-01 00:22:38.000000000 +0100
++++ src/c/resin_os/Makefile.in 2005-04-29 16:24:36.000000000 +0200
+@@ -13,7 +13,7 @@ resin_libexec=@apache_libexec@
+ resin_home=@resin_home@
+ JNI_INCLUDE=@JNI_INCLUDE@
+ INCLUDES = @INCLUDES@ $(JNI_INCLUDE) -I../common
+-CFLAGS = @CFLAGS@ -DRESIN_HOME=\"$(resin_home)\" $(INCLUDES) -DCPU=\"$(CPU)\" -DOS=$(OS)
++CFLAGS = @CFLAGS@ -fPIC -DRESIN_HOME=\"$(resin_home)\" $(INCLUDES) -DCPU=\"$(CPU)\" -DOS=$(OS)
+ OBJ= jni_os.o
+
+ all : libresin_os.$(SO)
diff --git a/www-servers/resin/resin-3.0.12.ebuild b/www-servers/resin/resin-3.0.12.ebuild
index 525cbecf3b6b..8438f5b61ab9 100644
--- a/www-servers/resin/resin-3.0.12.ebuild
+++ b/www-servers/resin/resin-3.0.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/resin/resin-3.0.12.ebuild,v 1.2 2005/04/19 14:03:56 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/resin/resin-3.0.12.ebuild,v 1.3 2005/04/29 14:31:00 luckyduck Exp $
inherit java-pkg eutils
@@ -21,6 +21,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${PV}/wrapper.pl.diff
+ epatch ${FILESDIR}/${PV}/gentoo.diff
}
pkg_preinst() {
@@ -40,8 +41,8 @@ pkg_preinst() {
}
src_compile() {
- ./configure --prefix=${D}${RESIN_HOME}
- make
+ ./configure --prefix=${D}${RESIN_HOME} || die "configure failed"
+ make || die "make failed"
}
src_install() {