summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-04-30 14:48:46 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-04-30 14:48:46 +0000
commitbe0dd7ce6026e9ec5efbc3249c09eed2fd241e3c (patch)
tree6a88ff287b58f199ba3a1f5009786acb6b6ed4d2 /www-apps/tikiwiki
parentFix bug #131721 (diff)
downloadhistorical-be0dd7ce6026e9ec5efbc3249c09eed2fd241e3c.tar.gz
historical-be0dd7ce6026e9ec5efbc3249c09eed2fd241e3c.tar.bz2
historical-be0dd7ce6026e9ec5efbc3249c09eed2fd241e3c.zip
Version bump
Package-Manager: portage-2.1_pre9-r5
Diffstat (limited to 'www-apps/tikiwiki')
-rw-r--r--www-apps/tikiwiki/ChangeLog8
-rw-r--r--www-apps/tikiwiki/files/digest-tikiwiki-1.9.33
-rw-r--r--www-apps/tikiwiki/tikiwiki-1.9.3.ebuild83
3 files changed, 93 insertions, 1 deletions
diff --git a/www-apps/tikiwiki/ChangeLog b/www-apps/tikiwiki/ChangeLog
index 3562d567afd7..3ed8cf7df30e 100644
--- a/www-apps/tikiwiki/ChangeLog
+++ b/www-apps/tikiwiki/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/tikiwiki
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.25 2006/02/07 14:16:48 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.26 2006/04/30 14:48:46 rl03 Exp $
+
+*tikiwiki-1.9.3 (30 Apr 2006)
+
+ 30 Apr 2006; Renat Lumpau <rl03@gentoo.org> -tikiwiki-1.9.2.ebuild,
+ +tikiwiki-1.9.3.ebuild:
+ Version bump
07 Feb 2006; Renat Lumpau <rl03@gentoo.org> -tikiwiki-1.8.6.ebuild,
tikiwiki-1.9.1.1.ebuild, tikiwiki-1.9.2.ebuild:
diff --git a/www-apps/tikiwiki/files/digest-tikiwiki-1.9.3 b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.3
new file mode 100644
index 000000000000..8ca2145a2c6c
--- /dev/null
+++ b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.3
@@ -0,0 +1,3 @@
+MD5 5aed26961df2ef07eba3b98ec6467853 tikiwiki-1.9.3.tar.bz2 6534047
+RMD160 ae328188074ee98dc4fbd3aff665f2f4095dbe29 tikiwiki-1.9.3.tar.bz2 6534047
+SHA256 aabd3e4d056de62981be8fc8ec494818332c55dc8311a1ef97d02dc5a7defe33 tikiwiki-1.9.3.tar.bz2 6534047
diff --git a/www-apps/tikiwiki/tikiwiki-1.9.3.ebuild b/www-apps/tikiwiki/tikiwiki-1.9.3.ebuild
new file mode 100644
index 000000000000..671381181978
--- /dev/null
+++ b/www-apps/tikiwiki/tikiwiki-1.9.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/tikiwiki-1.9.3.ebuild,v 1.1 2006/04/30 14:48:46 rl03 Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Full-featured Web Content Management System using PHP and Smarty Templates"
+HOMEPAGE="http://tikiwiki.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+IUSE="mysql postgres graphviz"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="virtual/php
+ mysql? ( >=dev-db/mysql-4 )
+ postgres? ( dev-db/postgresql )
+ graphviz? ( media-gfx/graphviz )
+"
+pkg_setup () {
+ webapp_pkg_setup
+ use mysql && require_php_with_use mysql
+ use postgres && require_php_with_use postgres
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local DIR
+ local DIRENTRY
+ local DIRS="backups db dump files img/trackers img/wiki
+ img/wiki_up modules/cache temp
+ templates_c templates styles maps whelp mods
+ lib/Galaxia/processes"
+
+ # Ensure that directories exist, some don't.
+ # (part of setup.sh)
+ for DIR in ${DIRS}; do
+ mkdir -p ${DIR}
+ done
+
+ # Remove the execute permission from the setup.sh script
+ # and rename it. Its actions have been incorporated here.
+ chmod a-x setup.sh
+ mv setup.sh setup.sh.done
+
+ # Install the minimal doc (points to web page)
+ #
+ dodoc doc/readme.txt doc/htaccess doc/htaccess.readme INSTALL README
+
+ # The bulk goes into htdocs
+ # but don't copy INSTALL and README
+ cp -pPR [[:lower:]]* ${D}/${MY_HTDOCSDIR}
+
+ # Recursively set server ownership to allow server to write
+ # This is the rough equivalent of the setup.sh script
+ # provided in the distribution.
+ # Note: Cannot use xargs or find -exec here because
+ # these don't work with shell functions.
+ #
+ webapp_serverowned ${MY_HTDOCSDIR}
+ for DIR in ${DIRS}; do
+ find ${DIR} | while read DIRENTRY; do
+ webapp_serverowned ${MY_HTDOCSDIR}/${DIRENTRY}
+ done
+ done
+ webapp_serverowned ${MY_HTDOCSDIR}/tiki-install.php
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_src_install
+}
+
+pkg_config() {
+ einfo "Type in your MySQL root password to create an empty tiki database:"
+ mysqladmin -u root -p create tikiwiki
+}
+
+pkg_postinst() {
+ einfo "To setup a MySQL database, run:"
+ einfo "\"emerge --config =${PF}\""
+ einfo "If you are using PostgreSQL, consult your documentation"
+ webapp_pkg_postinst
+}