summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-09-22 00:13:25 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-09-22 00:13:25 +0000
commitef7d2e723904c36d246e13d0aef40f387ae64497 (patch)
tree943a8030e611c0530f4b5f3fffc80754d5982b48 /www-apps/mambo/mambo-4.6.ebuild
parentforgot the die on the make check (diff)
downloadhistorical-ef7d2e723904c36d246e13d0aef40f387ae64497.tar.gz
historical-ef7d2e723904c36d246e13d0aef40f387ae64497.tar.bz2
historical-ef7d2e723904c36d246e13d0aef40f387ae64497.zip
Version bump
Package-Manager: portage-2.1.1_pre2-r6
Diffstat (limited to 'www-apps/mambo/mambo-4.6.ebuild')
-rw-r--r--www-apps/mambo/mambo-4.6.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/www-apps/mambo/mambo-4.6.ebuild b/www-apps/mambo/mambo-4.6.ebuild
new file mode 100644
index 000000000000..9d9116078ae6
--- /dev/null
+++ b/www-apps/mambo/mambo-4.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/mambo-4.6.ebuild,v 1.1 2006/09/22 00:13:25 rl03 Exp $
+
+inherit webapp depend.php
+
+MY_PN="${PN/m/M}"
+DESCRIPTION="Mambo is a dynamic portal engine and content management system"
+HOMEPAGE="http://www.mamboserver.com/"
+SRC_URI="http://mamboxchange.com/frs/download.php/8223/${MY_PN}v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+S=${WORKDIR}
+
+IUSE="mysql"
+
+RDEPEND="mysql? ( dev-db/mysql )
+ virtual/httpd-php
+ net-www/apache"
+
+pkg_setup () {
+ webapp_pkg_setup
+ require_php_with_use mysql zlib
+}
+
+src_install () {
+ webapp_src_preinst
+ local files="administrator/backups administrator/components components
+ images images/banners images/stories mambots mambots/content mambots/search
+ media language administrator/modules administrator/templates cache modules
+ templates mambots/editors mambots/editors-xtd uploadfiles"
+
+ dodoc CHANGELOG.php INSTALL.php README
+
+ cp -R [^d]* ${D}/${MY_HTDOCSDIR}
+
+ for file in ${files}; do
+ webapp_serverowned "${MY_HTDOCSDIR}/${file}"
+ done
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}